Web UI Doesn't Display Certain Tabs

Hello Everyone,

I’ve been banging my head against a wall with this problem for a week so if anyone can offer some guidance I’d appreciate it.

I have LibreNMS installed on Ubuntu 16.04 and I have several devices added using snmp, all of that is working well. There are a couple of devices I want to install check_mk on and eventually write some custom scripts to make sure certain file systems are mounted and that certain processes are running.

I’ve followed the instructions here pretty closely (https://docs.librenms.org/#Extensions/Agent-Setup/) but I’m not seeing the scripts anywhere in the LibreNMS web UI. This is the problem I’m looking to solve. I enabled “unix-agent” under the properties for this device. I copied the hddtemp script that came with the librenms-agent repository to /usr/lib/check_mk_agent/local on the device. If I telnet from LibreNMS to the device on port 6556 I get all of the output, including the hddtemp output.

When I run “sudo ./poller.php -h 192.168.1.x -d -m unix-agent | grep -i hddtemp” I can see hddtemp information being returned. Same thing when I run “sudo ./poller.php -r -f -h 192.168.1.x -d | grep -i hddtemp”, I see output from hddtemp. It just doesn’t show up at all in the LibreNMS web UI. I’ve seen screenshots from other people using check_mk and their device properties have “Apps” and “Processes” tabs between the “Health” and “Ports” tabs that I don’t have in my web UI.

Here is the output of ./validate.php:

sudo ./validate.php 
====================================
Component | Version
--------- | -------
LibreNMS  | 1.33-129-g51a641c
DB Schema | 215
PHP       | 7.0.22-0ubuntu0.16.04.1
MySQL     | 10.0.31-MariaDB-0ubuntu0.16.04.2
RRDTool   | 1.5.5
SNMP      | NET-SNMP 5.7.3
====================================

[OK]    Database connection successful
[OK]    Database schema correct

I’m not sure what it is I’m doing wrong. Let me know if there is any other information I should provide.