When click “Ports” under certain device shows Whoops, looks like something went wrong. Check your librenms.log

Hi Guys, my LibreNMS suddenly shows error if switch to ports. It only happen recently and only on certain devices.

What I have done :

*adding new devices (same brand/model…) but same error appear after 2-3 days.
*accessing specific Ports directly under Device utilization no issues
*run apt update & upgrade
*run ./daily
*restart server

Output of validate.php:

===========================================

Component Version
LibreNMS 24.6.0-16-g338e0acbe4 (2024-06-20T22:37:34+08:00)
DB Schema 2024_04_29_183605_custom_maps_drop_background_suffix_and_background_version (294)
PHP 8.1.2-1ubuntu2.18
Python 3.10.12
Database MariaDB 10.6.18-MariaDB-0ubuntu0.22.04.1
RRDTool 1.7.2
SNMP 5.9.1
===========================================

[OK] Composer Version: 2.7.7
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database Schema is current
[OK] SQL Server meets minimum requirements
[OK] lower_case_table_names is enabled
[OK] MySQL engine is optimal
[OK] Database and column collations are correct
[OK] Database schema correct
[OK] MySQL and PHP time match
[OK] Active pollers found
[OK] Dispatcher Service is enabled
[OK] Locks are functional
[OK] Python wrapper cron entry is not present
[OK] Redis is unavailable
[OK] rrdtool version ok
[OK] Connected to rrdcached

#Error appear at librenms.log when device Ports selected:


Missing required parameter for [Route: device] [URI: device/{device}/{tab?}/{vars?}] [Missing parameter: device]. {“view”:{“view”:“/opt/librenms/resources/views/components/device-link.blade.php”,“data”:},“userId”:2,“exception”:“[object] (Spatie\LaravelIgnition\Exceptions\ViewException(code: 0): Missing required parameter for [Route: device] [URI: device/{device}/{tab?}/{vars?}] [Missing parameter: device]. at /opt/librenms/vendor/laravel/framework/src/Illuminate/Routing/Exceptions/UrlGenerationException.php:35)
[previous exception] [object] (Illuminate\Routing\Exceptions\UrlGenerationException(code: 0): Missing required parameter for [Route: device] [URI: device/{device}/{tab?}/{vars?}] [Missing parameter: device]. at /opt/librenms/vendor/laravel/framework/src/Illuminate/Routing/Exceptions/UrlGenerationException.php:35)”}


I did try to fix it myself…but somehow end up corrupting the entire Ports sql table.
Manage to revert everything back to the last working snapshot…and now im back with working LibreNMS, but certain device remain can’t get into Ports page.

Any advice very much appreciated.

I have the same errors, but only on HPE 10GB switches.
I also get the same errors and have tried the same steps as siyut.

I have not tried to fix the problem myself. Does anybody have any idea why this could happen?

I have the same errors, for Mikrotik CR2004-16G-2S+ but not for all.

Just for the latest 2 added 2 weeks ago. Tried to re-add the device, with no luck.

Information is there when clicking individual port and graphs are plotted.

Thank you !

Some sort of bad data in your installs. Does anyone have a more complete back error trace? The one above is missing the important part.

But, I would still like to see a complete trace, because the fix will still result in a bad link, just no error message.

Hi murrant, apparently issues seems to be fix by itself…tested today, those Ports tab with ‘Whoops’ error back to normal.

re-run the ./daily and restart server…all seems ok now.

Thank you for support sir, really appreciate it.