Whoops, looks like something went wrong

This morning when I looked at my LibreNMS install I was greeted with a message:
Error: Missing dependencies! Run the following command to fix:
./scripts/composer_wrapper.php install --no-dev

After successfully installing mbstring using: yum install php71w-mbstring

Then running ./scripts/composer_wrapper.php install --no-dev as the librenms user.

I’m now stuck with the following error when trying to log into the webui:
Whoops, looks like something went wrong.


Component Version
LibreNMS 1.39-32-ge4bc556
DB Schema 249
PHP 7.1.16
MySQL 5.1.73
RRDTool 1.3.8


[OK] Composer Version: 1.6.5
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[WARN] fping6 does not have IPv6 support?!?!

have same issue only with “ports” page https://*/ports/
debug doesnt work either

I had the same, I fixed it like this Unable to access the WebUI

Didn’t work for me.

The key is set and I even restarted httpd but I still get the “Whoops, looks like something went wrong.” page.

Any other ideas? My monitoring system has been down all day and I need to get something working soon. :frowning:

At the point I’m not sure what to do and I haven’t had much help on here. :frowning:

This sucks because I have 3 installs that are doing this and they where working fine before this latest update. I really need to be able to monitor my network and I rather not move to another solution.

Can anyone help me?

Thanks in advance.

did you try rebooting the server ? I saw that fixed it for someone else
Running ./daily.sh again any errors?
post output of latest errors in /opt/librenms/logs/librenms.log

Don’t know if it’ll make a difference but I notice others are installing a previous version of mbstring to you
yum install php70w-mbstring rather than yum install php71w-mbstring. I would remove your version and try ./scripts/composer_wrapper.php install --no-dev again.

chown -R librenms:librenms /opt/librenms
(for good luck…!)

also don’t see any harm in trying php artisan key:generate again . I had to run it twice for some reason.

If all fails, i would look at why laravel is giving you this error. e.g https://stackoverflow.com/questions/28893710/whoops-looks-like-something-went-wrong-laravel-5-0

Yes, I’ve rebooted and that didn’t seem to help. I have also ran the daily.sh without errors.

But, I have completely forgot to look at the librenms.log file and there is something interesting in there:
[2018-05-11 10:23:37] production.ERROR: PDOException: SQLSTATE[42000]: Syntax error or access violation: 1115 Unknown character set: ‘utf8mb4’ in /opt/librenms/vendor/laravel/framework/src/Illuminate/Database/Connectors/MySqlConnector.php:56

It seem that it doesn’t like the character set for MySQL. Has anyone else had this issue?

You could try to replace these lines in /opt/librenms/config/database.php

            'charset' => 'utf8mb4',
            'collation' => 'utf8mb4_unicode_ci',


            'charset' => 'utf8',
            'collation' => 'utf8_unicode_ci ',

That being said, mine is default with utf8mb4 so i’m not sure whats different between our setups.

Might be worth a try?

1 Like

Thank you, thank you, thank you!

Not sure what’s different about my install (it’s very basic and followed the step in the wiki) but this fixed it for me! YAY!

1 Like

I have the same problem…

I changed to -
‘charset’ => ‘utf8’,
‘collation’ => 'utf8_unicode_ci ',

Still have error.



Did it get rid of your access violation errors in the log, any new errors?

If you you have made the change your your local files, you will need to remove those changes or updates will be blocked.

1 Like

Same errors.

This is confusing. I am still getting errors and its not working.



The fix isn’t merged yet.

ahh I see. So when the fix is merged, just do a that daily.sh?


It is merged now, run ./daily.sh and ./validate.php