XG Firewall showing all ports as deleted?

Hi, we have recently upgraded from Sophos’ UTM to the newer XG and upon adding the new device to LibreNMS all the discovered ports are immediately set as deleted?

I have tried purging deleted ports and also enabled the purge deleted ports option in the config, but as soon as I re-discover the device it puts them back in as deleted and the device page shows no ports. Is there a way to restore/undelete them that I am missing?

Any help would be much appreciated, thank you

Here is the output of my ./validate.php :

====================================
Component | Version
--------- | -------
LibreNMS  | 21.3.0-57-g6616727a9
DB Schema | 2021_02_09_122930_migrate_to_utf8mb4 (205)
PHP       | 7.4.16
Python    | 3.8.5
MySQL     | 10.3.25-MariaDB-0ubuntu0.20.04.1
RRDTool   | 1.7.2
SNMP      | NET-SNMP 5.8
====================================

[OK]    Composer Version: 2.0.11
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database schema correct
1 Like

I have the same problem have you found the solution yet?
Mario

No unfortunately not yet. I have even tried completely deleting the device after purging the ports but still no luck.

I have made a change to the settings, so far it works

Unfortunately it does not work :frowning:

Hi Mario, this morning my missing ports have come back. I’m not sure if it was something to do with the most recent update but you may want to check yours!

Edit: the update has fixed the ports on the XG but has now broken the ports on the older UTM devices!