1 minute polling and graphs

Is there a way to retain existing graphed data after switching to 1 minute polling?

I’ve switched to one minute polling, and I see in /opt/librenms/logs/librenms.log that this is working. I also added a new device, and I’m seeing the 1-minute polling data in interface traffic graphs. Yay!

From what I understand, the change to 1 minute polling will not affect existing rrd files.

Is it best to just delete the device and start over at this point, or disable polling for an existing device, rename it to whateverhostname-old or something like that, then add it again with the real hostname to force new rrd files?

I searched in the community and on the subreddit and couldn’t find anything, so if the solution is documented somewhere or if it’s obvious to others please forgive me :wink:

It’s not merged in yet but you can grab the script from the pr: https://github.com/librenms/librenms/pull/6081/files

Worked perfectly, thank you!

@laf is this the same as the rrdstep tool in the Read the docs portion of 1minute polling ?

Not sure how you’re getting to read the docs but our docs are on docs.librenms.org

But yes, it’s the rrd step change that the script does.

Sorry assumed they were on “read the doc” either way i mean the docs for Libre. Thanks. I ran it on the host whose graph i look at. Thank you


I’m not sure if you have a question still

u answered it by saying yes already. thank you

Hi, first time LibreNMS user. I am not very efficient in Linux nor LibreNMS. I managed to set up 1 Minute polling and confirmed that it works via /logs/librenms.log

Unfortunately I cannot seem to get the 1 minute graph updates to work. They still step in 5min intervals.

[email protected]:~$ ./validate.php

Component Version
LibreNMS 1.65.1
DB Schema 2020_06_23_00522_alter_availability_perc_column (170)
PHP 7.2.24-0ubuntu0.18.04.4
Python 3.6.9
MySQL 10.1.44-MariaDB-0ubuntu0.18.04.1
RRDTool 1.7.0

[OK] Composer Version: 1.10.9
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[WARN] Your local git contains modified files, this could prevent automatic updates.
You can fix this with ./scripts/github-remove
Modified Files:

I used the rrdstep.php config from the link feature: Added rrd step conversion script by laf · Pull Request #6081 · librenms/librenms · GitHub, which is why I am assuming the warning of modified files comes up. I did run the normal rrd file for 20min as well.

rrdtool graph /tmp/jGPXRfuSQYA7H4Ab --alt-autoscale-max --rigid -E --start 1595244600 --end 1595246400 --width 1728 --height 312 -c BACK#EEEEEE00 -c SHADEA#EEEEEE00 -c SHADEB#EEEEEE00 -c CANVAS#FFFFFF00 -c GRID#a5a5a5 -c MGRID#FF9999 -c FRAME#5e5e5e -c ARROW#5e5e5e -R normal -c FONT#000000 --font LEGEND:8:DejaVuSansMono --font AXIS:7:DejaVuSansMono --font-render-mode normal DEF:outoctets= DEF:inoctets= DEF:outoctets_max= DEF:inoctets_max= CDEF:octets=inoctets,outoctets,+ CDEF:doutoctets=outoctets,-1,* CDEF:outbits=outoctets,8,* CDEF:outbits_max=outoctets_max,8,* CDEF:doutoctets_max=outoctets_max,-1,* CDEF:doutbits=doutoctets,8,* CDEF:doutbits_max=doutoctets_max,8,* CDEF:inbits=inoctets,8,* CDEF:inbits_max=inoctets_max,8,* VDEF:totin=inoctets,TOTAL VDEF:totout=outoctets,TOTAL VDEF:tot=octets,TOTAL CDEF:dpercentile_outn=doutbits,-1,* VDEF:dpercentile_outnp=dpercentile_outn,95,PERCENT CDEF:dpercentile_outnpn=doutbits,doutbits,-,dpercentile_outnp,-1,,+ VDEF:dpercentile_out=dpercentile_outnpn,FIRST VDEF:percentile_in=inbits,95,PERCENT VDEF:percentile_out=outbits,95,PERCENT COMMENT:‘bps Now Ave Max 95th %\n’ AREA:inbits_max#D7FFC7: AREA:inbits#90B040: LINE:inbits#608720:‘In ’ GPRINT:inbits:LAST:%6.2lf%s GPRINT:inbits:AVERAGE:%6.2lf%s GPRINT:inbits_max:MAX:%6.2lf%s GPRINT:percentile_in:%6.2lf%s\n AREA:doutbits_max#E0E0FF: AREA:doutbits#8080C0: LINE:doutbits#606090:‘Out’ GPRINT:outbits:LAST:%6.2lf%s GPRINT:outbits:AVERAGE:%6.2lf%s GPRINT:outbits_max:MAX:%6.2lf%s GPRINT:percentile_out:%6.2lf%s\n GPRINT:tot:‘Total %6.2lf%sB’ GPRINT:totin:’(In %6.2lf%sB’ GPRINT:totout:‘Out %6.2lf%sB)\l’ LINE1:percentile_in#aa0000 LINE1:dpercentile_out#aa0000 VDEF:islope=inbits_max,LSLSLOPE VDEF:icons=inbits_max,LSLINT CDEF:ilsl=inbits_max,POP,islope,COUNT,,icons,+ LINE2:ilsl#44aa55:‘In Linear Prediction\n’:dashes=8 VDEF:oslope=doutbits_max,LSLSLOPE VDEF:ocons=doutbits_max,LSLINT CDEF:olsl=doutbits_max,POP,oslope,COUNT,*,ocons,+ LINE2:olsl#4400dd:‘Out Linear Prediction\n’:dashes=8 --daemon unix:/var/run/rrdcached/rrdcached.sock

RRDTool Output

OK u:0.24 s:0.02 r:0.26

Any assistance would be appreciated.