502 Bad Gateway nginx/1.18.0 after debiian update (dietpi) [solved]

As a rather inexperienced linux user I troubleshooted my way to this:

A dietpi-update brought the machine to debain 10

cat /proc/version
Linux version 5.10.0-27-amd64 ([email protected]) (gcc-10 (Debian 10.2.1-6) 10.2.1 20210110, GNU ld (GNU Binutils for Debian) 2.35.2) #1 SMP Debian 5.10.205-2 (2023-12-31)

./validate reported.
Timezone was of in php.ini. Fixed that.
Still 502.

So, next step. Found in the forum here about php upgrad.
php had been upgraded to 8.3 and the librenms.conf was not in place for 8.3
Solved by copying the file from my 8.2 folder, /etc/php/8.3/fpm/pool.d:

root@nms2:/etc/php/8.3/fpm/pool.d# cp …/…/…/8.2/fpm/pool.d/librenms.conf .

Up and running again.
Awesome software by the way!

1 Like

I follow these step, but for me still doesn’t work, can you help me please?

I’m by no mean an expert in this field. Some intense search here in the forums I found answers.

I can try to assist.

Where do you get stuck?
You know what made it not work? An upgrade?

Everything OK from validator?

You got a librenms.conf in your latest php-folder? In my case it was an upgrade 8.3 when I apt update or the debian got up to version 10. What’s your linux dist?
I can rewrite the copy I did so it’s more obvious the from an to part.
: cp /etc/php/8.3/fpm/pool.d/librenms.conf /etc/php/8.3/fpm/pool.d/.