504 Gateway Time-out on About LibreNMS


When clicking on about LibreNMS I’m getting a 504 Gateway Time-out page I’ve look through a few topics related to 504 errors but I’m not sure how to debug php.

:~$ ./validate.php
Component | Version
--------- | -------
LibreNMS  | 23.11.0-3-gac61c3835 (2023-11-17T05:24:29-08:00)
DB Schema | 2023_11_04_125846_packages_increase_name_column_length (273)
PHP       | 8.1.2-1ubuntu2.14
Python    | 3.10.12
Database  | MariaDB 10.6.12-MariaDB-0ubuntu0.22.04.1
RRDTool   | 1.7.2
SNMP      | 5.9.1

[OK]    Composer Version: 2.6.5
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[OK]    Database Schema is current
[OK]    SQL Server meets minimum requirements
[OK]    lower_case_table_names is enabled
[OK]    MySQL engine is optimal
[OK]    Database and column collations are correct
[OK]    Database schema correct
[OK]    MySQl and PHP time match
[OK]    Active pollers found
[OK]    Dispatcher Service not detected
[OK]    Locks are functional
[OK]    Python poller wrapper is polling
[OK]    Redis is unavailable
[OK]    rrdtool version ok
[OK]    Connected to rrdcached

Check your webserver logs and also /opt/librenms/logs/librenms.log

1 Like

Increased the timeout settings as a Band-Aid but this is not a fix.

following this community question

You log shows that php-fpm is hitting pool limits and restarting, I’d suggest sorting that first. Google will help as it’s not a Lnms question really.

1 Like

Now I’m getting a 504 time out error and restarting mariadb service 2x a day 3 of 5 days a week “Fixes” the issue temporarily

Any suggestions?