Add new device huawei

Please provide ALL info asked for here.
add this device
Huawei YunShan OS
Version (S5700 V600R022C01SPC500)
Copyright (C) 2021-2022 Huawei Technologies Co., Ltd.
HUAWEI CloudEngine S5735-L-V2

Hi @Gopal_Ubhale
A lot of details are missing here so there is no way to add your device.

give me suggetion im provide all details

Look at your first post, there is a link, follow it, and provide all that was requested …

Hello @Gopal_Ubhale

To easily add this device, you must enter its administration website and configure SNMP.

Depending on the configuration you define there, then go to LibreNMS and:

Devices > AddDevice

You enter the IP and SNMP parameters (consistent with what you entered on the switch).

With this, it should now work correctly.

In a few minutes the SNMP query would be run and the values and graphs would begin to appear.



Bumping this thread as we’re also requesting device support for Huawei YunShan OS. Linking the requested output from the FAQ:

Best regards


This device is very similar to Huawei VRP and all checks works. I’ve added new sysDescr - “YunShan OS” to includes/definitions/vrp.yaml which works fine. Disadvatage is that it will be rewritten after the upgrade, so I’d really appreciate new OS.


Hi @ls_jesus
You can submit your change as a Pull Request to get it merged. I would suggest indeed to create a new OS.

I submitted the PR Add support for Huawei YunShan OS by czarnian · Pull Request #15903 · librenms/librenms · GitHub for YunShan OS and it is merged already. So basic support is done.

1 Like

Hello @czarnian,

Great, I can see that your PR was released in 24.3.0. I tried it, but unfortunately it didn’t work. I have a model USG6725F and it doesn’t know OID . However, I’ve modifed the discovery to check sysDescr and it worked fine with all health checks:

    - sysObjectID:
        - .
    - sysDescr:
        - Huawei YunShan OS

If it is better to to do the discovery with specific OID, there is one that is implemented in mine and also in @unwillingcontributor - .

-> snmpwalk -v2c -c public .
SNMPv2-SMI::enterprises.2011. = STRING: "YunShan OS"

Could you please take a look at it when you will find some spare time?

Many thanks!

Thank you for the information - I have already noticed that the discovery is not reliable. YunShan and VRP sometimes have the same OID and sometimes the OID is not even present. I will fix that to sysDescr asap.

Also, there are issues with PoE and FDB discoveries, but those are above my skills. I can provide more details and test data, if someone would be interested.