Adding new OS for FS (Fiberswitch) DWDM gear (multiple optics)

Following the “Support for a new OS” DOCs, I’ve created the following YAML:

os: fs-dwdm
text: ‘Fiberstore DWDM’
type: network
icon: fs
group: fs
- sysObjectID:
- .
- sysDescr:
- ‘enterprises’
mib_dir: fs

When I run ./discovery.php -h fs.dwdm.hostname -d it throws a lot of errors, and ends up discovering 1 device.

I can successfully walk the device with snmpwalk -Cc -v 1 -m ALL -c public fs.dwdm.hostname enterprises and it dumps the follow snippet:

OAP-C2-OEO::vSFPB2ModeTransmissionRate.0 = INTEGER: 10300
OAP-C2-OEO::vSFPB2ModeTemperature.0 = INTEGER: 4184
OAP-C2-OEO::vSFPB2TxPowerAlarm.0 = INTEGER: normal(1)
OAP-C2-OEO::vSFPB2RxPowerAlarm.0 = INTEGER: normal(1)
OAP-C2-OEO::vSFPB2ModeTemperatureAlarm.0 = INTEGER: normal(1)
OAP-C2-OEO::vSFPB2.13.0 = INTEGER: -2000
OAP-C2-OEO::vSFPC1State.0 = INTEGER: on(1)
OAP-C2-OEO::vSFPC1WorkMode.0 = INTEGER: normal(1)
OAP-C2-OEO::vSFPC1TxPowerControl.0 = INTEGER: auto(2)
OAP-C2-OEO::vSFPC1TxPower.0 = INTEGER: 222

Each OEO has it’s own .my MIB file, and that gets a little confusing later on in the polling the OS section as it seems to allow only 1?

Assistance and guidance would be appreciated.

has to be the exact name you have librenms

…yes, this is a place holder for the real hostname of the device added via the GUI. sorry if that wasn’t clear.

Interestingly, tried it again, and the log in the GUI shows the following:

Device OS changed: generic → fs-nmu

I wonder why it’s picking up the that instead.

I’ve tracked it down to the DWDMs needing -Cc as a flag for snmpwalk instead of the default -c

How do you change these defaults?

Tracked down why the device is being assigned fs-nmu as the OS instead of the new OS I’ve written a .yaml file for.

Device returns multiple sysObjectIDs, with the first sysObjectID matching the sysObjectID of the fs-nmu.yaml, and then the sysObjectID which I had hoped to match with my new OS (I named it fs-dwdm.yaml).

How do you deal with this kind of situation in LibreNMS?

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.