After updating from php 8.0 to 8.1, Your Composer dependencies require a PHP version ">= 8.1.0"

[email protected]:~$ ./validate.php

Component Version
LibreNMS 23.4.0-5-g8809779b8 (2023-04-07T11:09:31+09:00)
DB Schema 2023_03_14_130653_migrate_empty_user_funcs_to_null (249)
PHP 8.1.17
Python 3.8.10
Database MariaDB 10.3.38-MariaDB-0ubuntu0.20.04.1
RRDTool 1.7.2
SNMP 5.8
===========================================

[OK] Composer Version: 2.5.5
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database Schema is current
[OK] SQL Server meets minimum requirements
[OK] lower_case_table_names is enabled
[OK] MySQL engine is optimal
[OK] Database and column collations are correct
[OK] Database schema correct
[OK] MySQl and PHP time match
[OK] Active pollers found
[OK] Dispatcher Service not detected
[OK] Locks are functional
[OK] Python poller wrapper is polling
[OK] Redis is unavailable
[OK] rrd_dir is writable
[OK] rrdtool version ok

I updated from php 8.0 to 8.1 (ubuntu 22.04.2 LTS)
but, The following error is occurring when accessing the web page.

Composer detected issues in your platform: Your Composer dependencies require a PHP version ā€œ>= 8.1.0ā€.

Iā€™m asking for a solution.

Firstly I would check if you have php 8.0 still running:

systemctl | grep php

If not then maybe ensure the timezone is set correctly:

vi /etc/php/8.2/fpm/php.ini
vi /etc/php/8.2/cli/php.ini

Finally confirm the PHP-FPM is configured correctly as per the install guide:

After all of this try a PHP service restart and then an update and validate of nms and see how you are going:

systemctl restart php8.1-fpm
su - librenms
./daily.sh
./validate.sh