Alert about CPU usage while that alert isn't enabled to begin with


Suddenly, out of nowhere, I am getting email alerts that the CPU-usage of one of my Synologies is > 85%:

Alert for device - Processor usage over 85%

%title Severity: %severity {if %state == 0}Time elapsed: %elapsed {/if}Timestamp: %timestamp Unique-ID: %uid Rule: {if %name}%name{else}%rule{/if} {if %faults}Faults: {foreach %faults} #%key: %value.string {/foreach}{/if}Alert sent to: {foreach %contacts}%value

But there isn’t any alert rule active for this to begin with. How can I disable this?

It’s flooding my email inbox.

Here is a picture of my alert rules (they are defaults, I didn’t add any):

I am on version [1.54 - Mon Jul 29 2019 04:47:34 GMT+0200] since it is a Docker container from JariSchaeffer and there isn’t a newer one available yet.

Thank you for any help,


I think it might be related to a sensor alert rule nacigate to /alerts and it will show you what alert rule is tripping the sensor.

You can then add an exclusion for this host in the sensor rule

Thank you for your reply.

I don’t know where /alerts is :frowning:

I have Alerts/Notifications, where it only shows Port Status Up/Down for this host.

And I have Alerts/Alert History, where it shows no alerts for today for this host.

The weird thing is: in General Settings/Alerting settings I just disabled email alerting, but the alerts keep on coming on. Going back into General Settings the email alerting was enabled again by itself.

It gets worse. The alerts keep on coming in. I suspected the disabled email alerting was set to enabled again, but … it is not.

So now LNMS is even ignoring that setting, in addition to send me emails I didn’t ask for.

I’ll now for the time being try to remove the email sending account.

It wouldn’t surprise me if it still keeps on sending emails :slight_smile:

I am not kidding…

I changed the email user from librenms to librenms1, so of course it shouldn’t be able to send alerts anymore — but it does…

I am not kidding…

(Simply deleting the user isn’t working, LNMS puts it back in, so the only option is to change the user)

Apparently, restarting the docker container finally made the alerts stop, as in: it now respects the fake email user.

Now am going to restore that back to the original user, and enable alerting again, to see if I again get alerts I didn’t ask for.

And all problems solved: no more alerts I didn’t ask for. Restarting the container seems to be the solution.

What remains is that it is weird that LNMS starts sending alerts not asked for, and even does so when the email account is changed into a fake one.

Time for beer :slight_smile: