Alerting only the sysContact of a device

alerting
Tags: #<Tag:0x00007fe225905330>

#1

Hi,

It seems I have problem with alerting / notifications or perhaps a misunderstanding of the concept of alerting.

My librenms is up for about 2 years right now. With the daily update working fine. I monitor about 200 devices via snmp, mostly servers under linux and windows.

I have the standard alert rules (up/down device, storage, up/down services, …)

Since the new alert system / template update, I think the mail notifications is quite broken here.

Here is what I would like to do and it’s not working :

  • send an alert to sysContact of a device matching any common rules (up/down device, storage, up/down service,…), I haven’t define any transport for those rules.

Things that are working :

  • specific rule map to a specific device or group of device and associated with a transport.

Issue alerts to sysContact is ON in General Alert Settings

Override sysContact is checked under Alert Settings of the device with an email address in the field.

Updates to contact email addresses not honored’ is set to OFF in the WebUI.

./scripts/test-alert.php -r 1 -h 269 -d : https://p.libren.ms/view/6dfb4ebc : alert is only sent to the default contact

According to the doc

The contacts will always include the SysContact defined in the Device’s SNMP configuration

How can I debug that part ?

./validate.php : https://p.libren.ms/view/e85ce8e4

I hope I am quite clear…

Thanks,
Pierre-Damien


#2

I managed to get it working !

I build a test platform with the docker image / docker-compose (congratulations to the team, the docker-compose is awesome)

On this test platform, everything was working as expected. So why not working on my prod ? I notice this sql request in the debug SELECT transport_id, transport_type, transport_name FROM alert_transports WHERE is_default=TRUE : I had a mail transport which was define to default, it seems that setting was problematic.

I also disabling issue alerts to admins, read only users, normal users, just let copy all email alerts to default contact.

Perhaps can we improve that part in the docs ? Or I miss something ?

Pierre-Damien


#3

We have exactly the same problem and I can find no way to make it work using the syscontact. Whatever we try it ends up being sent to the default transport only and, if we turn that off, it complains there is no default transport. Ideally, we want emails only to the syscontact for each device. How do we achieve that?


#4

It seems like the default template always just emails the default contact. I set up a desktop for testing purposes and, whilst it claims to have emailed the syscontact, it has only emailed the default contact. Surely I don’t need a separate template for every set of contacts or do I?


#5

By globally enabling email alerting and removing the default email transport, I seem to have achieved what I want. Is this likely to break anything else?