Alerts don't send e-mail, but e-mail transport test works

Hi,

I don’t know what I’m doing wrong here. When I first set up this box my test alerts worked just fine, but now that I’ve added a few more boxen to the monitoring, no e-mails go out when an alert is triggered. If I test the transport though it works fine.

Near as I can tell it knows its supposed to be sending e-mail, and it’s capable of sending e-mail, but when it gets an alert, it decides not to send an e-mail. There is no record of any failed entries in /var/log/maillog, only my tests (and cron mailers).

I’ve read through all the other e-mail not working posts here and the first 3 pages of Google. I’m really at a loss. It’s probably something stupid, but I can’t find it. Any help would be very much appreciated.

[[email protected] ~]# sudo -u librenms /u01/librenms/validate.php

Component Version
LibreNMS 1.32-2-gf1b5073
DB Schema 209
PHP 7.0.23
MySQL 5.5.56-MariaDB
RRDTool 1.4.8
SNMP NET-SNMP 5.7.2
====================================

[OK] Database connection successful
[OK] Database schema correct

output of alerts.php -d:

output of config.php:
https://pastebin.com/yvyRU6fM

output of alerts capture on one of the machines:

Alert and e-mail transport settings:



(I have tried with and without a default contact. It makes no difference. I have also tried sendmail and smtp. No difference.)

Event log contents:

Alert history showing it is picking up alerts:

Test rule I created to guarantee a trigger:

Nice work troubleshooting and providing lots of details. :smile:

try this in the Mail transport change the How to deliver mail to “mail”

image

Also, have you changed any of the alert templates?

Thanks for replying so quickly!

I just looked at my alert template and I think I have it figured out. It looks like I had an errant {/if} in there that was tripping it up. This is what I get for trying to get fancy.

Thanks!