Alerts.php broken after Distributed Poller setup

Last week I migrated a stand alone instance into a distributed poller setup and added a poller. Everything works fine except for the alerts. Validate doesn’t show anything exciting that could be wrong.

If I step through alerts.php it fails to get a lock via these lines and skips over the whole process.

$alerts_lock = Cache::lock(‘alerts’, \LibreNMS\Config::get(‘service_alerting_frequency’));
if ($alerts_lock->get()) {

If I run the test-alerts and test-templates, they run successfully. I’m using memcached for the locking tool. I have this in /etc/sysconfig/memcached
OPTIONS="-l 10.180.x.x"

Here are the installed memcached pieces:
yum list installed | grep memcached
libmemcached-opt-libs.x86_64 1.0.18-2.el7.remi @remi-safe
memcached.x86_64 1.4.15-10.el7_3.1 @base
php74-php-pecl-memcached.x86_64 3.1.5-1.el7.remi @remi-safe
python-memcached.noarch 1.48-4.el7 @base

I have this line in /opt/librenms/.env

I have this in /opt/librenms/config.php
$config[‘distributed_poller_memcached_host’] = “10.180.x.x”;
$config[‘distributed_poller_memcached_port’] = 11211;

Where should I look next?

remove CACHE_DRIVER=memcached and see if this helps.
Normally this will switch to sql lock

1 Like

That fixed it. thanks!