Alerts sent to Google Chat and Email transports not escaping properly


I have configured some alerting rules on a new installation of LibreNMS. Everything seems to work okay except for the fact that I get a weird subject lines in both Email (I’m using the web Gmail client) and Google Chat.

validate.php output:
bash-5.1$ ./validate.php

Component Version
LibreNMS 22.8.0
DB Schema 2022_07_19_081224_plugins_unique_index (244)
PHP 8.0.22
Python 3.10.5
Database MariaDB 10.8.4-MariaDB-1:10.8.4+maria~ubu2204
RRDTool 1.7.2
SNMP 5.9.3

[OK] Installed from the official Docker image; no Composer required
[OK] Database connection successful
[OK] Database Schema is current
[OK] SQL Server meets minimum requirements
[OK] lower_case_table_names is enabled
[OK] MySQL engine is optimal
[OK] Database schema correct
[OK] MySQl and PHP time match
[OK] Distributed Polling setting is enabled globally
[OK] Connected to rrdcached
[WARN] PHP version 8.1 is the minimum supported version as of September, 2022. We recommend you update PHP to a supported version (8.1 suggested) to continue to receive updates. If you do not update PHP, LibreNMS will continue to function but stop receiving bug fixes and updates.
[OK] Active pollers found
[OK] Dispatcher Service is enabled
[OK] Locks are functional
[OK] No python wrapper pollers found
[OK] Redis is functional
[WARN] IPv6 is disabled on your server, you will not be able to add IPv6 devices.
[OK] rrdtool version ok
[OK] Connected to rrdcached
[WARN] Updates are managed through the official Docker image

The subject appears as “{{ $alert->title }} - critical”
The Alert Title in the template is: “{{ $alert->title }}”

It does seem to be specific to alert titles though as “{{ $alert->timestamp }}” and “{{ $alert->uid }}” seem to render fine.

I have enabled “email_html” in the global configuration.

Any ideas on what I could try to make the subject appear correctly?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.