Aruba Instant state sensor alert for disabled radio

<%- if @topic_view.topic.tags.present? %>
<%= t 'js.tagging.tags' %>: <%- @topic_view.topic.tags.each do |t| %> <%= t %> <%- end %>
<% end %>

Hi,

I’ve just disabled some 2.4GHz radios on Aruba Instant APs, with the use of the dot11g-radio-disable command on each APs. That worked fine, but I then started to have an alert in regards to State Sensor Warning on the virtual controller that is monitored.

When looking at the details, it does show that the state of that given AP’s radio 0 is down. So that’s “expected”, after disabling it, but not sure if it’s a different state than when it’s not voluntarily down. When I edit the virtual controller device, I can remove all of the alerts for that radio (utilization, power, etc), but not the one for its state. Is there somewhere else that I could fully disable that sensor? Or is the only way to acknowledge until clear? It creates false “noise” when looking at the list of alerts, so would be nice not to see it there, if possible.

Thanks!

Hi,

I have submitted a fix for this. https://github.com/librenms/librenms/pull/10335

1 Like

Wow, thanks for the quick turnaround! I’ll definitely test this out ASAP

Thanks again, applied the patch and got the up alert.

Just in case, yes, the state of the sensor is still marked as down.

I’ve just upgraded to 1.53.1 - Tue Jul 02 2019 08:11:58 GMT-0400 and although the fixes are in, it doesn’t seem to work anymore. It had cleared the alert for the disabled radio, but now it’s back. Any idea if it’s linked to another update? Let me know if you need me to provide anything. Thanks!

OK, this is really weird.

I’ve just checked, and I’m still at the same LibreNMS version: 1.53.1 - Tue Jul 02 2019 08:11:58 GMT-0400

These were the alarms that I got yesterday:


2019-07-03 18:45:41		

ap_virtual_controller_name
#1: SERIAL_NUMBER Radio 1;  
Current Value: 2 (state)

State Sensor Warning

2019-07-03 18:45:42

ap_name
#1: SERIAL_NUMBER Radio 1;  
Current Value: 2 (state)

State Sensor Warning

And these are the OK that I got during the night:


2019-07-04 00:45:41

ap_name

#1: SERIAL_NUMBER Radio 1;  
Current Value: 2 (state)

State Sensor Warning

2019-07-04 00:45:39		

virtual_controller_name
#1: SERIAL_NUMBER Radio 1;  
Current Value: 2 (state)

State Sensor Warning

These are the only things I have in daily.log for today:

[ Thu, 04 Jul 2019 00:15:13 -0400 ] http://www.librenms.org/notifications.rss (43)
[ Thu, 04 Jul 2019 00:15:13 -0400 ] misc/notifications.rss (53)
[ Thu, 04 Jul 2019 00:15:13 -0400 ] Updating DB  Done
Returned: 0
Caching PeeringDB data
Peering DB integration disabled
Returned: 0

I thought that the update_channel was properly set to release:

# Uncomment the next line to disable daily updates
#$config['update'] = 0;
$config['update_channel'] = 'release';

Yet I have some files that were updated today (besides cache, logs and storage framework):

vendor/autoload.php
vendor/composer/ClassLoader.php
vendor/composer/autoload_static.php
vendor/composer/installed.json
vendor/composer/autoload_real.php
vendor/composer/autoload_classmap.php
vendor/composer/autoload_psr4.php
vendor/composer/autoload_namespaces.php
vendor/composer/LICENSE
vendor/composer/autoload_files.php
bootstrap/cache/services.php
bootstrap/cache/packages.php
.git/index
.git/FETCH_HEAD

Does this mean that the update_channel is not release and that we’re not following the stable branch?

Thanks again!