Auto discovery issues

I seem to have a strange problem with my auto discovery rules.

I have turned off my auto discovery rule inside the config.php file and deleted the devices i do not want it to scan but they seem to keep coming back when the discovery runs.

Can anybody help me get rid of the unwanted devices and make sure they don’t get discovered again?

can you validate your install and also post your config with the discovery?

thanks for the fast reply i hope this is what you need:

]# ./validate.php

Component Version
LibreNMS 1.31-3-gd5bfd1d
DB Schema 205
PHP 5.4.16
MySQL 5.5.52-MariaDB
RRDTool 1.4.8


[OK] Database connection successful
[OK] Database schema correct
[WARN] Some devices have not been polled in the last 5 minutes.
You may have performance issues. Check your poll log and see:
and 1 more…


Have a look in includes/ for examples of settings you can set here. DO NOT EDIT!

Database config

$config[‘db_host’] = ‘localhost’;
$config[‘db_user’] = ‘librenms’;
$config[‘db_pass’] = ‘********’;
$config[‘db_name’] = ‘librenms’;

// This is the user LibreNMS will run as
//Please ensure this user is created and has the correct permissions to your install
$config[‘user’] = ‘librenms’;

This should only be set if you want to force a particular hostname/port

It will prevent the web interface being usable form any other hostname

$config[‘base_url’] = “/”;

Enable this to use rrdcached. Be sure rrd_dir is within the rrdcached dir

and that your web server has permission to talk to rrdcached.

#$config[‘rrdcached’] = “unix:/var/run/rrdcached.sock”;

Default community

$config[‘snmp’][‘community’][] = “public”;
$config[‘snmp’][‘community’][] = “********”;

Authentication Model

$config[‘auth_mechanism’] = “mysql”; # default, other options: ldap, http-auth
#$config[‘http_auth_guest’] = “guest”; # remember to configure this user if you use http-auth

List of RFC1918 networks to allow scanning-based discovery

#$config[‘nets’][] = “”;

Uncomment the next line to disable daily updates

#$config[‘update’] = 0;

Number in days of how long to keep old rrd files. 0 disables this feature

$config[‘rrd_purge’] = 0;

Uncomment to submit callback stats via proxy

#$config[‘callback_proxy’] = “hostname:port”;

Set default port association mode for new devices (default: ifIndex)

#$config[‘default_port_association_mode’] = ‘ifIndex’;

Enable the in-built billing extension

$config[‘enable_billing’] = 1;

Enable the in-built services support (Nagios plugins)

$config[‘show_services’] = 1;
$config[‘nagios_plugins’] = “/usr/lib/nagios/plugins”;

Enable auto discovery methods

$config[‘discovery_modules’][‘discovery-arp’] = 1;
$config[‘addhost_alwayscheckip’] = true;
$config[‘fping’] = “/usr/sbin/fping”;

$config[‘allow_unauth_graphs’] = 1;

looks like its still on

$config[‘discovery_modules’][‘discovery-arp’] = 1

Should i comment it out or set it to 0?

not sure try 0

I’ll give it a shot and let you know, thank you very much for this!

keep in mind you can exclude

will do!

Thanks again.