Auto-Update Broken Due to Git Branch Merge Error

So last night I got an alert that PHP 7.1 and Python 2.x are losing support moving forward. The alert advises to go to PHP 7.3 and Python 3.x. So I update my LNMS box to the appropriate versions: PHP 7.3.18 and Python 3.6.9, then running through pip with the requirements.txt file and rerunning validate.php for good measure to which there were no outstanding issues.

I tried rerunning daily.sh and eventually I get a " Your configuration specifies to merge with the ref ‘php71-python2’ from the remote, but no such ref was fetched." error on the git pull call. Looking at the daily.sh script it seems that it’s really only looking for Python 3 and PHP newer than 7.1, but there it doesn’t seem like there are any modifications made to the .git/config file to indicate what branch should be pulled from.

Before and after running daily.sh, this is what my .git/config looks like:

[[email protected] .git]# cat config
[core]
repositoryformatversion = 0
filemode = true
bare = false
logallrefupdates = true
[remote “origin”]
fetch = +refs/heads/:refs/remotes/origin/
url = https://github.com/librenms/librenms.git
[branch “master”]
remote = origin
merge = refs/heads/master
[branch “php53”]
remote = origin
merge = refs/heads/php53
[branch “php71-python2”]
remote = origin
merge = refs/heads/php71-python2

I would’ve expected some sort of consistent branch stanza like “php73-python3”, but I’m not quite seeing what this should be for the pull to work.

Any ideas/advice? Here’s my relevant output from validate.php:

Component Version
LibreNMS 1.63-56-gf3ad810
DB Schema 2020_04_13_150500_add_last_error_fields_to_bgp_peers (164)
PHP 7.3.18
Python 3.6.9
MySQL 5.1.73
RRDTool 1.3.8
SNMP NET-SNMP 5.5

please run ./validate.php we need the full output of ./validate.php

Thanks for checking in, but I think I solved my own issue. I had to do a checkout on master then pull.