Autodiscovery Issue


I’ve got some problems with the autodiscovery which actually doesn’t works on my installation.
I think everything what necessary was configured, see below my “config.php” file please for a double-check.
Anyhow nothing will be automatically added,
even if I run manually the command inside the “/etc/cron.d/librenms” file.

Thanks for your feedbacks, kind regards
Ivan Biasi.

config.php file

//Please ensure this user is created and has the correct permissions to your install
$config[‘user’] = ‘librenms’;

#$config[‘base_url’] = “/”;

#$config[‘rrdcached’] = “unix:/var/run/rrdcached.sock”;

Default community

#$config[‘snmp’][‘community’] = array(‘public’);
$config[‘snmp’][‘community’][] = “blabla1”;
$config[‘snmp’][‘community’][] = “blabla2”;
$config[‘snmp’][‘community’][] = “<and_others>”;

Authentication Model

$config[‘auth_mechanism’] = “mysql”; # default, other options: ldap, http-auth
#$config[‘http_auth_guest’] = “guest”; # remember to configure this user if you use http-auth

List of RFC1918 networks to allow scanning-based discovery

#$config[‘nets’][] = “”;
$config[‘nets’][] = “<networkA_to_scan/24>”;
$config[‘nets’][] = “<networkB_to_scan/27>”;
$config[‘nets’][] = “<networkC_to_scan/26>”;
$config[‘nets’][] = “<networkD_to_scan/28>”;

$config[‘discovery_by_ip’] = true;
$config[‘mydomain’] = ‘<>’;

Discovery Methods

$config[‘discovery_modules’][‘discovery-arp’] = true;
$config[‘autodiscovery’][‘xdp’] = true;
$config[‘autodiscovery’][‘ospf’] = true;
$config[‘autodiscovery’][‘bgp’] = true;
$config[‘os’][‘linux’][‘poller_modules’][‘unix-agent’] = true;
$config[‘os’][‘win’][‘poller_modules’][‘unix-agent’] = true;
$config[‘os’][‘windows’][‘poller_modules’][‘unix-agent’] = true;
$config[‘os’][‘microsoft windows’][‘poller_modules’][‘unix-agent’] = true;


$config[‘map’][‘engine’] = “leaflet”;
$config[‘leaflet’][‘default_lat’] = “44.04509”;
$config[‘leaflet’][‘default_lng’] = “14.12960”;
$config[‘leaflet’][‘default_zoom’] = 9;
// Device grouping radius in KM default 80KM
$config[‘leaflet’][‘group_radius’] = 1;

Hi all

I repeated the autodiscovery process and finally it goes fine.
Be aware that, before run the autodiscovery, as requested I manually added a couple of VMs into the monitored devices.
I solved manually adding, into the monitored devices,
also a router placed on one of the networks to be discovered.
After that the autodiscovery started to work properly.

I hope it can be helpful for someone.
Kind regards

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.