Bind Graph doesn´t show any statistics


#1

Hi,

I want to configure libreNMS to monitor Bind Service. So I followed up the instructions, explained in the docs: https://docs.librenms.org/#Extensions/Applications/#bind9-aka-named

But the Bind-graphs doesn´t show anything

cat /var/run/named/stats
Is filled up with expected data

rndc stats && cat /var/run/named/stats
Gives a valid output without permission errors.

named.conf.options contains the necessary entry that includes the stat-file:

statistics-file "/var/run/named/stats";
zone-statistics yes;

What I do not understand ist the following part in the docs:

You may possibly need to configure the agent/extend script as well.

The config file’s path defaults to the same path as the script, but with .config appended. So if the script is located at /etc/snmp/bind, the config file will be /etc/snmp/bind.config. Alternatively you can also specify a config via

I Need to create the bind.config which contains the values for the variables that are already stored in the bind script itself?

OK, I´am not a coder, but a normal sysadmin - so I created the file with the following content:

rndc = /usr/bin/env
call_rndc = 1
stats_file = /var/run/named/stats
agent = 0
zero_stats = 0

Hoever, with, or without the bind.config - the bind graphs doesn´t show anything.

Any advice how to get this to work?


#2

I´ve issued ./poller.php -h 192.168.10.2 -d where the IP is the Server which is running the bind service.
The output contains all the DNS-Data needed to feed the graphs. But the graphs are still empty :frowning:

Any suggestions?


#3

I just figured out that the snmpd service status gives an error:

duplicate table data attempted to be entered. row exists
Failed to register extend entry 'bind' - possibly duplicate name.

Do you have any idea why this can be caused?


#4

Pastebin the output of the poller debug you ran.


#5

done!

https://pastebin.com/KDYudTpc


#6

That output doesn’t look right. Did you by chance download the bind script in /librenms-agent/agent-local to run as a check_mk agent? Because that’s outdated. I opened an issue a while back because github wouldn’t let me do a PR that just deleted a single file for some reason at the time.

If you want to use the agent, download the bind script in /librenms-agent/snmp and change the variable for agent. Otherwise just use the snmp extend method. No need to do both.


#7

Yes I did! As mentioned in the Doc. Installing the agent is suggestet there! Since there is no note to either install the script to /etc/snmp/bind or instal the agent - I did both.

I removes all components with the agent and still get the same output from service snmpd restart:

Mai 25 15:14:10 dns-server systemd[1]: Starting LSB: SNMP agents...
Mai 25 15:14:10 dns-server snmpd[9344]:  * Starting SNMP services:
Mai 25 15:14:10 dns-server snmpd[9349]: duplicate table data attempted to be entered. row exists
Mai 25 15:14:10 dns-server snmpd[9349]: Failed to register extend entry 'bind' - possibly duplicate name.
Mai 25 15:14:10 dns-server snmpd[9351]: NET-SNMP version 5.7.3
Mai 25 15:14:10 dns-server systemd[1]: Started LSB: SNMP agents.

Sorry but I´very new to SNMP and libreNMS.


#8

I think if the introduction section to applications it says snmp or agent. Not in the individual applications themselves.

But that error looks like you might have more than one extend bind line in your snmpd.conf file?


#9

There is only one extend statement in the snmpd.conf
When I remove it, snmpd service starts normally…

Have really no idea what do :frowning:


#10

Well, I’m not sure either but here are a couple ideas for you…

If you’re using the snmpd.conf that came with your distro, you might try moving it somewhere else and replacing it with the very basic example file from librenms (/opt/librenms/snmpd.conf.example). See if you can get snmpd to run with that first, then add the bind extend and see if that works. If you still get the same error maybe try running…
snmpd -f -Le -Dread_config
…with sudo or as root.

One of the first couple lines should be read_config:path: and that should tell you where all snmpd is looking for conf files. After that it should show your line-by-line what config snmpd is loading from each of those files. Look through the output and see if you can spot any extends or OID’s that might conflict.

Or since you seem to have the check_mk agent running anyway you could just go that route. Don’t do the snmpd extend, remove that old bind script from /usr/lib/check_mk_agent/local/, move the new bind script and the bind.config file from /etc/snmp to /usr/lib/check_mk_agent/local/, and edit the config settings to agent = 1


#11

Whenever I have found the ‘duplicate’ entry, it is usually the same command in multiple .conf files.

snmpd reads all the .conf files it can fine, from different directories. Have a read of man snmpd.conf perhaps.


#12

You must beware of selinux and chroot.