BindingResolutionException on template create/update


Once updated to cde15ce, we had converted our alert templates to a new Laravel Blade syntax. This functionality actually worked fine, we indeed swapped templates from previous syntax to the current one using convertion functionality. During evaluation period we understood that alert syntax can be adjusted to a better representation, so this morning I tried to edit alert templates, but actually failed to do so once we updated to 9bc0c54. Even with slight edits like adding a space to the text or adding a completely new template from examples in the documentation results in the following error in the web interface: “An error occurred updating this alert template.” (even if template is created and not updated).

In the logs the following trace output can be found:

2018/07/31 05:41:12 [error] 1273#0: *41944 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught exception 'Illuminate\Contracts\Container\BindingResolutionException' with message 'Target [Illuminate\Contracts\View\Factory] is not instantiable.' in /opt/librenms/vendor/laravel/framework/src/Illuminate/Container/Container.php:895
Stack trace:
#0 /opt/librenms/vendor/laravel/framework/src/Illuminate/Container/Container.php(735): Illuminate\Container\Container->notInstantiable('Illuminate\\Cont...')
#1 /opt/librenms/vendor/laravel/framework/src/Illuminate/Container/Container.php(608): Illuminate\Container\Container->build('Illuminate\\Cont...')
#2 /opt/librenms/vendor/laravel/framework/src/Illuminate/Container/Container.php(575): Illuminate\Container\Container->resolve('Illuminate\\Cont...')
#3 /opt/librenms/vendor/laravel/framework/src/Illuminate/Foundation/helpers.php(106): Illuminate\Container\Container->make('Illuminate\\Cont...')
#4 /opt/librenms/vendor/laravel/framework/src/Illuminate/Foundation/helpers.php(879): app('Illuminate\\Cont...')
#5 /opt/librenms/h" while reading response header from upstream, client:, server:, request: "POST /ajax_form.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "", referrer: ""

Validation output with trimmed hostnames (extra table is from a custom plugin):

Component | Version
--------- | -------
LibreNMS  | 1.41-71-g9bc0c54
DB Schema | 257
PHP       | 5.6.30-0+deb8u1
MySQL     | 5.7.20
RRDTool   | 1.6.0

[OK]    Composer Version: 1.6.5
[OK]    Dependencies up-to-date.
[OK]    Database connection successful
[FAIL]  Database: extra table (plugin_config_rules)
[FAIL]  We have detected that your database schema may be wrong, please report the following to us on IRC or the community site (
        [FIX] Run the following SQL statements to fix.
        SQL Statements:
         DROP TABLE `plugin_config_rules`;
[WARN]  Some devices have not been polled in the last 5 minutes. You may have performance issues.
        [FIX] Check your poll log and see:
[FAIL]  Some devices have not completed their polling run in 5 minutes, this will create gaps in data.
        [FIX] Check your poll log and see:
          and 164 more...
[WARN]  Your local git contains modified files, this could prevent automatic updates.
        [FIX] You can fix this with ./scripts/github-remove
        Modified Files:

Say please, how can I resolve the issue?

This has been solved with da58c91 commit.

That commit didn’t solve it. It had something to do with the state of your vendor directory. Likely, ./ fixed it (even if there was no code updates). I wonder what the issue was.