Bintec Router

we have a lot of Bintec router in our System.
No one of them will work with LibreNMS. All
devices will shown as generic device with no Interfaces.
What can we do ?

You will need to submit request new device os support in git hub, PLEASE PROVIDE ALL INFO REQUESTED IN THE TEMPLATE DO NOT DELETE THE INFO in the template.

Click here submit new device

Requesting info see here - All info that is required for add new device os support.

or you can code it yourself and make a pull request.

After some checks the problem is the snmpbulkwalk.
with the snmpbulkwalk the answer from the device is "timeout"
When i manually use snmpwalk it works.
Is there a possibility for some device to use snmpwalk


./discovery.php -r -f -h HOSTNAME -d

and use to post your output please

here is the Output

and here are the different Outputs from snmpbulkwalk and snmpwalk
which i manually test

I think sysobject-id is different than the bintec-smart.yaml
your is .

the ones in here are

may need to add them in

already done that
no effect
there is a problem with the snmpbulkwalk with that devices
the snmpwalk works


is there any news ???

franky try this maybe it will help im not sure.

Set a max repeater value within the snmp settings for a device. What to set this to is tricky, you really should run an snmpbulkwalk with -Cr10 through -Cr50 to see what works best. 50 is usually a good choice if the device can cope.

try that but no changes !!!

i think the Goal should be to use the snmpwalk for that devices

Do you think this is for all bintec devices or just this particular one?

We can disable snmpbulkwalk per os:

Probably just need to do that and add your sysObjectID.

1 Like

thanks for your response!

thats now our bintec.yaml file

os: bintec
text: 'Bintec Router’
type: network
icon: bintec
nobulk: true
- { graph: device_bits, text: ‘Device Traffic’ }
- { graph: device_fortigate_cpu, text: ‘CPU Usage’ }
- { graph: device_mempool, text: ‘Memory Usage’ }
- sysObjectId:
- .

but still librenms use snmpbulkwalk

that was my fault. Now the discovery and the polling works with nobulk: true.
But libre dont build graphs.

is there a possibility to use onl the vendor mibs from bintec:
in the .yaml i add the mib_dir function, but i can see that this
mibs are used additionally to the libre standard mibs.
Can i exclude some or all standard mibs ?

LibreNMS does not automatically use mibs.

You should submit your changes, or modify config.php to make the same settings instead.