Bug report


#1

Hi!

Not in need of help, want to report a WebUI bug.
I’m using PHP 7.3.1 but get a notification that my PHP version is to low since the latest daily update.

Output of validation.php:

====================================

Component Version
LibreNMS 1.48.1-27-gc7c1ca2
DB Schema 2019_01_16_195644_add_vrf_id_and_bgpLocalAs (131)
PHP 7.3.1-1+ubuntu16.04.1+deb.sury.org+1
MySQL 10.0.36-MariaDB-0ubuntu0.16.04.1
RRDTool 1.5.5
SNMP NET-SNMP 5.7.3

====================================

[OK] Composer Version: 1.8.3
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct


Notification message:

Error: PHP version too low

PHP version 7.1.3 is the minimum supported version as of February 1st, 2019. We recommend you update to PHP a supported version of PHP (7.2 suggested) to continue to receive updates. If you do not update PHP, LibreNMS will continue to function but stop receiving bug fixes and updates.

2019-02-07 00:00:00 | Source: daily.sh

/Pato


#2

Same issue here:

Component Version
LibreNMS 1.48.1-27-gc7c1ca2c5
DB Schema 2019_01_16_195644_add_vrf_id_and_bgpLocalAs (131)
PHP 7.2.10-0ubuntu0.18.04.1
MySQL 10.1.34-MariaDB-0ubuntu0.18.04.1
RRDTool 1.7.0
SNMP NET-SNMP 5.7.3

====================================

[OK] Composer Version: 1.8.3
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct


#3

@Ricardo_Viteri You are running PHP 7.2.

Are you saying that you also get the PHP version too low notification?


#4

@PatoVidal check Form and email validations do not work with PHP 7.3.1


#5

Yep

image


#6

Ok. Confirming this: I do also get the notification with php 7.2


PHP version too low [which is not] Issue
#7

I also got this notification with PHP 7.3


#8

Fix is merged, sorry about the false alarm :slight_smile: