Calix GPON switch now polling over 5 minutes, any thoughts to improve this?


#1

This is when it hit 5 minutes and I start to get spikes on interfaces every once in a while in 10 minute intervals. This switch will probably grow to a few more hundred ports on it until it is full. It has around 700 now, so just wondering if anyone has any thoughts to get it under 5 minutes without increasing poll time to 10minutes, I really do not want my alerts to be delayed another 5 minutes. I have also disabled polling on all ports not being used, and that did not decrease the poll time. Thoughts?


#2

See here -> https://docs.librenms.org/Support/FAQ/#faq17


#3

The GPON ONT support is kinda dumb on the Calix equipement. It talks to each ONT to get the data every time you poll, no caching is done.

The best way I’ve seen is to enable selected port polling and disable ports you don’t need.

Complain to TAC while you are at it :wink:


#4

Thanks murrant, this worked great. I didn’t have the selected port polling enabled, this cut it down to about 2 minutes. Yeah, I think I will have to open up another TAC case to give them a nudge.