Cambium PMP Processor Usage

With the newest code release on the Cambium 450 platform, it now looks like there is an OID for monitoring the processor. I’m trying to add this so that it can be graphed and thought I had the correct process in mind but doesn’t appear to be working. I added the following to the pmp.yaml file in /opt/librenms/definitions/discovery.

			oid: WHISP-BOX-MIBV2-MIB::currentCpuUsage
			value: currentCpuUsage
			num_oid: '.{{ $index }}'
			index: 0
			descr: 'Processor'

I rediscovered one of the devices and this didn’t work. Maybe I’m on the wrong track, I thought I remember seeing something about this in the documentation but have been unable to find it again. Any help would be appreciated.


Component Version
LibreNMS 1.47-87-g45e0e5e19
DB Schema 1000
PHP 7.0.27-0+deb9u1
MySQL 10.1.26-MariaDB-0+deb9u1
RRDTool 1.6.0


Did you clear the os definitions cache? (as stated in the docs

Thank you, I couldn’t find that page earlier this morning. I tried again with after clearing the cache and I’m still not seeing graphs for the CPU usage show up. I’m fairly certain I’m missing quite a bit after digging through the OS support doc’s. I’ve rolled back my changes so that daily will run and will see what I can come up with tomorrow.

So, after digging through the linked doc’s, as best I can tell, I should only have to add the above information on the pmp.yaml file and it should start graphing but that doesn’t appear to be the case. Any other ideas?

Anybody have any idea’s on this one? I’m stumped.

pastebin the output of ./discovery.php -h THEHOSTNAME -d
./poller.php -h THEHOSTNAME -d Discovery Poller