Can anyone else get an API Post to devicegroups to work?


I’ve got a fresh install of LibreNMS. I can query (GET) /api/v0/devicegroups just fine. Trying to create a devicegroup always fails. I’m even pasting in the examples given on the LibreNMS docs and switching around the device id and hostname and it’s failing. What I really want is to create dynamic groups, and I still get the same error when using the LibreNMS dynamic group example and my own variations. I suppose I want to see if this is happening to others as well or if I’m just being an idiot and overlooking something incredibly basic.

curl -H ‘X-Auth-Token: *******************************’
-d ‘{“name”:“New Device Group”,“type”:“static”,“devices”:[1]}’
“status”: “error”,
“message”: “We couldn’t parse your rule”

A quick GET sample (not the full output)

❯ curl -H ‘X-Auth-Token: ********************’
“status”: “ok”,
“groups”: [
“id”: 4,
“name”: “edgeswitch”,
“desc”: null,
“type”: “dynamic”,
“rules”: {
“condition”: “AND”,
“rules”: [
“id”: “devices.sysName”,
“field”: “devices.sysName”,
“type”: “string”,
“input”: “text”,
“operator”: “contains”,
“value”: “edgeswitch”
“valid”: true,
“joins”: []
“pattern”: null

Did you got any answer about this issue?

I am running into the same problem