Can not create new alert rules


I’m having an issue with one of our LibreNMS-servers when creating alerts. When I’m clicking on Create new Alert rule under the Alert menu, I am not able to build a filter with the integration buttons.

See the picture below. The first picture named “1” is a working LibreNMS. The second one is labeled “2” and is the faulty one. As you can see the buttons isn’t showing up. I have tried ./ and reboot of the server but can’t figure it out.

Output of ./validate.php:

librenms@STSLIBNMS02:~$ ./validate.php

Component Version
LibreNMS 23.8.2-41-ga1eb90fe6 (2023-09-12T10:05:08+02:00)
DB Schema 2023_08_30_105156_add_applications_soft_deleted (259)
PHP 8.1.23
Python 3.8.10
Database MariaDB 10.3.38-MariaDB-0ubuntu0.20.04.1
RRDTool 1.7.2
SNMP 5.8

[OK] Composer Version: 2.6.2
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database Schema is current
[OK] SQL Server meets minimum requirements
[OK] lower_case_table_names is enabled
[OK] MySQL engine is optimal
[OK] Database and column collations are correct
[OK] Database schema correct
[OK] MySQl and PHP time match
[OK] Active pollers found
[OK] Dispatcher Service not detected
[OK] Locks are functional
[OK] Python poller wrapper is polling
[OK] Redis is unavailable
[OK] rrdtool version ok
[OK] Connected to rrdcached

Your second image appears to be missing the icon for the “Docs” shortcut at the top.

I would check your web browsers developer console for errors to see why that is missing. You’re probably not loading all the metadata required to render the UI.

Maybe even deleting your browsers cache or trying another web browser may yield better results.

Yep, likely something has happened that broke url links.

I upgraded php on the libre server which solved the problem. (Different web browsers didn’t make any diff).

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.