Can not to access the WebUI

[root@librenms ~]# /opt/librenms/validate.php

Component Version
LibreNMS 1.39-32-ge4bc556
DB Schema 249
PHP 7.0.19
MySQL 5.5.52-MariaDB
RRDTool 1.4.8

[OK] Composer Version: 1.6.5
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[root@librenms ~]# /opt/librenms/
Re-running /opt/librenms/ as librenms user
Updating to latest codebase OK
Updating Composer packages OK
Updating SQL-Schema OK
Updating submodules OK
Cleaning up DB OK
Fetching notifications OK
Caching PeeringDB data OK
[root@librenms ~]#
[root@librenms ~]# getenforce

pleases help me can not to access the WebUI

error msg:
Error: bootstrap/cache, storage, storage/framework/sessions, storage/framework/views, storage/framework/cache, logs not writable! Run these commands as root on your LibreNMS server to fix:
chown -R librenms:librenms /opt/librenms/bootstrap/cache /opt/librenms/storage /opt/librenms/storage/framework/sessions /opt/librenms/storage/framework/views /opt/librenms/storage/framework/cache /opt/librenms/logs

setfacl -R -m g::rwx /opt/librenms/bootstrap/cache /opt/librenms/storage /opt/librenms/storage/framework/sessions /opt/librenms/storage/framework/views /opt/librenms/storage/framework/cache /opt/librenms/logs

setfacl -d -m g::rwx /opt/librenms/bootstrap/cache /opt/librenms/storage /opt/librenms/storage/framework/sessions /opt/librenms/storage/framework/views /opt/librenms/storage/framework/cache /opt/librenms/logs

usermod -a -G librenms apache

Try “php artisan key:generate” and add the generate key into the “.env” file as the “APP_KEY”.

If that doesn’t work, repeat with “php artisan key:generate --force”…

Let me know if that works for you!

[root@librenms librenms]# php artisan key:generate
PHP Notice: date_default_timezone_set(): Timezone ID ‘’ is invalid in /opt/librenms/vendor/laravel/framework/src/Illuminate/Foundation/Bootstrap/LoadConfiguration.php on line 49

  • Application In Production!     *

Do you really wish to run this command? (yes/no) [no]:


Application key [base64:h+09pKTmLVs7jAxyBOZw858FQ+Lc8jb7sYX+oSnNVMs=] set successfully.
[root@librenms librenms]# pwd
[root@librenms librenms]#


Reinstall the mbstring PHP extension if needed, then execute:

/opt/librenms/scripts/composer_wrapper.php install --no-dev

If that finished successfully, in case you use SELinux, execute:

mkdir -p /opt/librenms/bootstrap/cache /opt/librenms/storage
chown -R librenms:librenms /opt/librenms/bootstrap/cache /opt/librenms/storage
setfacl -R -m g::rwx /opt/librenms/bootstrap/cache /opt/librenms/storage
setfacl -d -m g::rwx /opt/librenms/bootstrap/cache /opt/librenms/storage
semanage fcontext -a -t httpd_sys_content_t '/opt/librenms/bootstrap/cache(/.*)?'
semanage fcontext -a -t httpd_sys_rw_content_t '/opt/librenms/bootstrap/cache(/.*)?'
restorecon -RFvv /opt/librenms/bootstrap/cache
semanage fcontext -a -t httpd_sys_content_t '/opt/librenms/storage(/.*)?'
semanage fcontext -a -t httpd_sys_rw_content_t '/opt/librenms/storage(/.*)?'
restorecon -RFvv /opt/librenms/storage

You should then be able to access your web UI again.

I am having this same issue and neither of these solutions have worked. Any other thoughts?

I am still the same error message!! help!!

i fix it
Every helper thanks!!

centos 6.x

[root@librenms ~]# yum install php70w php70w-opcache
Dependency Updated:
libtidy.x86_64 0:5.4.0-1.el7 openssl.x86_64 1:1.0.2k-12.el7 openssl-libs.x86_64 1:1.0.2k-12.el7
php70w-bcmath.x86_64 0:7.0.29-1.w7 php70w-cli.x86_64 0:7.0.29-1.w7 php70w-common.x86_64 0:7.0.29-1.w7
php70w-fpm.x86_64 0:7.0.29-1.w7 php70w-gd.x86_64 0:7.0.29-1.w7 php70w-mbstring.x86_64 0:7.0.29-1.w7
php70w-mcrypt.x86_64 0:7.0.29-1.w7 php70w-pdo.x86_64 0:7.0.29-1.w7 php70w-process.x86_64 0:7.0.29-1.w7
php70w-snmp.x86_64 0:7.0.29-1.w7 php70w-tidy.x86_64 0:7.0.29-1.w7 php70w-xml.x86_64 0:7.0.29-1.w7

[root@librenms ~]# /opt/librenms/scripts/composer_wrapper.php install --no-dev
Do not run Composer as root/super user! See for details

Loading composer repositories with package information
Installing dependencies from lock file
Nothing to install or update
Generating autoload files
php artisan optimize
Generating optimized class loader
The compiled services file has been removed.
[root@librenms ~]#