Can´t add Windows devices

Hello people!!

I´m newbie with LibreNMS, i´m trying to make it run.

I´ve mounted the Ubuntu OVA in Virtualbox, no problem with this.

I can browse the webGUI and see the Ubuntu server (localhost)

But when I tried to add my machine (host), through SNMP, it can´t.

In Windows 10, I´ve configured the SNMP service with no problem (Comunitty, SNMP packets accepted from my server…). I can reach port 161 from Ubuntu terminal. Ping is also ok

Even I´ve made a Wireshark capture, in which I could see the LibreNMS send the SNMP get-request packets to Windows 10 ip machine, but nothing happens…After 6 tries, it stopped.

On Virtualbox network adapter, port 161 is forwarded (nmap says OPEN for Windows machine testing)

LibreNMS config is ok.

./ discovery result

./poller result

Validate Config says everything´s ok

I don´t know how to follow or what to do…Could anybody help me, please???

Thank you all!

Check the local firewall on the windows 10 device. By default it doesn’t open up the ports.

Thank you for the answer! port 161 is opened in Windows Firewall.

With command netstat -an, this is the result:


Anny other suggestions?? Thank you so much!!

Ok, after some testings with MIB Browser for localhost, everything was OK, I could read all the information.

So I checked the allowed host IPs and I realised that librenms host IP was wrong! after changing it, worked fine!

Now you can close this thread and kill me :stuck_out_tongue:

Thanks everyone!

1 Like