Cannot add widgets

New install of librenms on Ububtu 18.04, using the following guide, https://docs.librenms.org/Installation/Installation-Ubuntu-1804-Nginx/.

Validate config shows all is good.

Accessing gui through Google Chrome.

When I attempt to edit the default dashboard to add a widget, my browser redirects me to http://librenms.example.com/#

this happens with any widget.

Thoughts?

Thank you.

any “unusal” setup like reverse proxy, different domain/hostname/directory etc etc ?

No, this install was done step by step using the guide mentioned in my first post.
Thanks.

Something has been missed configured that’s not unusual. Are you sure you didn’t miss a step in the doc?

Also please run validate.php and post it.

I don’t believe I missed a step, but I certainly wouldn’t rule it out, I’ve made mistakes before…

Below is the output from validate.php

[email protected]_nms:/opt/librenms# ./validate.php

Component Version
LibreNMS 1.58.1-38-g535469de5
DB Schema 2019_10_03_211702_serialize_config (147)
PHP 7.2.24-0ubuntu0.18.04.1
MySQL 10.1.43-MariaDB-0ubuntu0.18.04.1
RRDTool 1.7.0
SNMP NET-SNMP 5.7.3

====================================

[OK] Composer Version: 1.9.1
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[email protected]_nms:/opt/librenms#

Thank you.

Ok, let me first start by saying thank you for all of the quick responses. Secondly, it appears that typing lessons are in order…

As it turns out, I apparently misspelled the filename for my librenms.conf file when I changed the server name. Problem solved!

1 Like

Hi, Validate config shows all is good.

I added localhost and hp, aruba switch.

Add widgets error occurs in the dashboard section.

Error message:librenms.example.com ’s server IP address could not be found.

====================================

Component Version
LibreNMS 1.59-66-g761d10584
DB Schema 2020_01_09_1300_migrate_devices_attribs_table (155)
PHP 7.2.24-0ubuntu0.18.04.2
MySQL 10.1.43-MariaDB-0ubuntu0.18.04.1
RRDTool 1.7.0
SNMP NET-SNMP 5.7.3

====================================

[OK] Composer Version: 1.9.2
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct

Global settings > System > Server > Specific URL :
You must type the localhost ip address.

That did the trick, Thank You!!