Can't install, problem w/ composer


#1

I am using this guide to install on the RPi: https://docs.librenms.org/Installation/Installation-Ubuntu-1604-Apache/

And am getting this issue: https://imgur.com/qpNQXHF

can anyone help me get past it?


#2

For raspberry pi install guide check this out


#3

Yep, you are missing some requirements.


#4

So it looks like my pi didn’t have current date/time so after a fresh iso install and time fix, some of the composer issued disappeared, but now am at this problem:

Imgur

Ideas?


#5

You need either a newer version of PHP (7.1+, 7.3 recommended) or an old version of LibreNMS (not recommended)


#6

The problem is there are no newer versions available on the pi as of yet, and forcing them breaks or won’t install correctly.
I just had it working till a power outage corrupted it and now can’t get it back up.


#7

What did you try? There are some instructions that might help here.

Try searching the web, you should be able to find something.


#8

Most of the steps here: https://janw.me/2019/installing-php7-3-rapsberry-pi/
As well as the comment here: LibreNMS on Raspberry Pi
about changing the repo, but no luck on either.

Is there a way to install a version that is older to just get it to install?