CentOS - Devices not showing up


I recently installed the latest and greatest of libreNMS although everything is working as it should no devices actually show up in the website

However if I do navigate to http://host/device/device=1, or 2 or whatever the device shows up without issues all data is updating

I ran the validate.php and no issues there - any idea why nothing is showing up under all devices, and respective sub-category?

post the out put validate.php

Also check here ->


Check your javascript console.

I’m not sure what you mean by check my javascript console - on my client? I tried from a few different machines and i’m getting the same thing

php memory size is set to 128M

rrdcached is running

If I add a Juniper device it shows up under routing but nothing under all devices

Here is the output of validate

Component Version
LibreNMS |
DB Schema | 213
PHP | 7.1.10
MySQL | 5.5.56-MariaDB
RRDTool | 1.4.8

[OK] Database connection successful
[OK] Database schema correct
[WARN] Your local git branch is not master, this will prevent automatic updates

My box is not internet connected hence the last warning

I’m having the same issue pointed out here

I’m using http-auth and created multiple users and none of them see anything