Cisco WLC polling issue #again

Due to a bug in Cisco WLC (Cisco won’t fix) LibreNMS suddenly stopped polling our WLC.

Error message:
Caching OIDs: entPhysicalDescrSNMP[’/usr/bin/snmpbulkwalk’ ‘-v2c’ ‘-c’ ‘COMMUNITY’ ‘-OQUs’ ‘-m’ ‘ENTITY-MIB’ ‘-M’ ‘/home/librenms/mibs:/home/librenms/mibs/cisco’ ‘udp:HOSTNAME:161’ ‘entPhysicalDescr’]
Exitcode: 1
Error: OID not increasing: entPhysicalDescr.1008

= entPhysicalDescr.936

The workaround is to use -Cc in snmpwalk, can this option be set for WLC devices only in LibreNMS?

Pass flags to snmpwalk specific to device
Cisco WLC polling issue

The last work around i mentioned before to hack snmp.inc.php with -Cc flag looks like not working right now :frowning: or i could not figure out where to apply it again.

Any clue guys ?

Still with issues and no reply at all … help !!!

Hi @Ygor_Almeida
Currently, there is no way, to my knowledge, to change flags for a specific device in the standard MIBs. Only in the YAML discovery currently. So you either need to suggest a fix and contribute it, or wait for somebody to do it for you.
Bye