Confused with LibreNMS Install Documentation (PHP and WebUI)

Hey Community,

This is my first attempt to install LibreNMS… I’m installing on a ProxMox container which uses Ubuntu 22.0.4, MariaDB, NGINX, and PHP version 8.1. I don’t quite understand the LibreNMS installation documentation for configuring PHP.

Would like to note the instructions I’m following: Installing LibreNMS - LibreNMS Docs

Can someone clarify the below? What is fastcgi_pass, am I supposed to change the listen link to /run/php-fpm-librenms.sock or changes the listen link to fastsci_pass location?

Change listen to a unique path that must match your webserver’s config (fastcgi_pass for NGINX and SetHandler for Apache) :

listen = /run/php-fpm-librenms.sock

My next question is when I browse to the ip address of the Librenms Server I am presented with the default Welcome to NGINX index page. I’m not sure what I missed in the steps and when I go through them I think I have done everything…

thoughts?

Thanks,

Joe

We only support Nginx on Ubuntu 22.04 so just copy and paste what’s in the docs.

rm /etc/nginx/sites-enabled/default
systemctl restart nginx
systemctl restart php8.1-fpm

You should just need to copy and paste all the commands pretty much verbatim

Thanks laf! I copied the listen statement, I’m just not clear on what the intent of fastcgi_pass is. I did miss the remove default file so I appreciate pointing that out. One thing I would note on the documentation at the end is, browsing to the hostname of the new server I had to put a /dashboard after ip address (fqdn) in order for the LibreNMS webui to display instead of NGINX welcome page.

Thanks for all the help!

This might help explain what fastcgi is: https://www.reddit.com/r/webdev/comments/ulvk8/can_anyone_explain_like_i_am_5_what_is_fastcgi/

The default nginx site was conflicting with the librenms config, you shouldn’t have that issue now you’ve deleted the default site. However it’s worth setting base_url to what the URL to your install is, run validate in the settings via WebUI and it should help.

Thanks laf! Makes sense the LibreNMS site and NGINx default site conflicting since I didn’t remove it. The reddit page makes fastCGI understandable, thanks for all of your help! I’m able to load the page into the WebUI now. I was able to run the update in settings but not sure where to set the base_url.