Custom OID graphs gone after nightly update

After last night’s update my custom OIDs are broken - the graphs are no longer displayed. For example, these are from a Raspberry Pi with a temperature sensor in my loft:

These were working fine until this morning. I have another device with a couple of custom OIDs and it’s the same there.

Any idea how I can fix this?

validate.php reports no issues, and I have tried rebooting. I also tried adding a new custom OID and that one also fails to produce a graph. The OID values are being read successfully.

I have also found that the data is still being recorded and the graphs are visible if I go directly to URLs like this:


We have the same problem.

It looks like this started after commit 4e6a7291a204b712284ffed9361cba472981a154 .

It seems to work if I undo the changes to from that commit, but I haven’t had time to track down what broke (I don’t recommend this as a workaround, as I’m not sure what it will break).

git show 4e6a7291a204b712284ffed9361cba472981a154 includes/html/pages/device/ | git apply --reverse

This new conditional seems to be causing the problem:

if (is_file("includes/html/pages/device/graphs/$")) {
    include "includes/html/pages/device/graphs/$";
} else {
    // original code

If I remove/rename this file the custom OID graphs are shown again:


I don’t know if that’s a valid workaround?

+1 here, I posted on Reddit and it seems there are at least 8 other people confirming as well.

Seems to be broken by

Confirmed fixed! Thanks for the quick turnaround!

It looks like the commit that broke this may have just exposed a problem in /includes/html/pages/graphs/ It looks like that file was not being used before.

Working again for me now too (after putting /opt/librenms/includes/html/pages/device/graphs/ back again :slight_smile: )