D-link switch shows up as generic device

Hi all,

I have a D-link DGS-1210-24 and it is showing as a generic device in LibreNMS. LibreNMS is installed in a Debian 10 container on ProxMox, however I have seen similar behavior in the downloaded VM and intermittently when I was running LibreNMS on a Raspberry PI 2 (slow, but functional).

I have tried removing and re-adding the switch to LibreNMS (which temporarily showed the D-link logo). I have also tried a manual ‘git pull’ in the /opt/librenms folder and a manual ./daily.sh. The issue remains.

I have rediscovered the device several times and this has not solved the issue. I have noticed on systems where it has worked that the device has become “Generic” after a rediscovery.

I also have a DGS-1210-10P and it is displayed correctly and also with the correct logo. No POE statistics are displayed for it, however this is understandable considering that only maximum POE is reported. I created a custom OID for this (iso.3.6.1.2.1.105.1.3.1.1.4.1).

What else can I try?

I’ve tried Observium in the past and the device was displayed correctly in there, however I would prefer not to use Observium for obvious reasons.

For ./discovery.php -h -d see: https://p.libren.ms/view/adfc7e5b

What is the output of:

'/usr/bin/snmpget' '-v2c' '-c' 'COMMUNITY' '-OUQn' '-m' 'SNMPv2-MIB' '-M' '/opt/librenms/mibs' 'udp:HOSTNAME:161' 'sysName.0' 'sysObjectID.0' 'sysDescr.0'

(with correct community and hostname entered)

It seems to not return anything from the debug output…

I’ve run '/usr/bin/snmpget' '-v2c' '-c' 'COMMUNITY' '-OUQn' '-m' 'SNMPv2-MIB' '-M' '/opt/librenms/mibs' 'udp:HOSTNAME:161' 'sysName.0' 'sysObjectID.0' 'sysDescr.0' from the CLI and get Timeout: No Response from udp:192.168.1.252:161..

I can snmpwalk the device:
[email protected]:/opt/librenms# snmpwalk -v 2c -c COMMUNITY HOSTNAME

and get an output (full output can be provided if needed):
iso.3.6.1.2.1.1.1.0 = STRING: “DGS-1210-24 4.21.B008”
iso.3.6.1.2.1.1.2.0 = OID: iso.3.6.1.4.1.171.10.76.24
iso.3.6.1.2.1.1.3.0 = Timeticks: (112807346) 13 days, 1:21:13.46

Both run from the CLI on the LibreNMS machine as root and librenms to be sure.

Seems like an issue with the device if it doesn’t reply to the snmpget…

Try one at a time. (just sysName.0, sysObjectID.0 and sysDescr.0)

Same issue with those other ones. It used to work with LibreNMS then became intermittent, Should I try resetting the switch to factory defaults?

Has the method to get data from SNMP changed recently?

Data is coming through on the graphs

There is a chance that could help.

That worked thank you. Now time to reconfigure and see where it breaks. I had noticed it becoming intermittent, looks like it was just my switch. Thank you for your help :slight_smile: