Daily.sh reporting the wrong PHP version in Web UI


#1

Hello,

As of 2019-02-08 I have a notification on the web frontend that informs me that my PHP version is too low, and that the minimum supported version is 7.1. The source of the message is daily.sh .

However when I run validate.php and daily.sh everything is OK, I only have version 7.2.14 of PHP installed.

Output from validate.php:

====================================

Component Version
LibreNMS 1.48.1-27-gc7c1ca2
DB Schema 2019_01_16_195644_add_vrf_id_and_bgpLocalAs (131)
PHP 7.2.14
MySQL 10.3.12-MariaDB
RRDTool 1.4.8
SNMP NET-SNMP 5.7.2

====================================

[OK] Composer Version: 1.8.3
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct

Output from daily.sh:

Re-running /opt/librenms/daily.sh as librenms user
Updating to latest codebase OK
Updating Composer packages OK
Updating SQL-Schema OK
Updating submodules OK
Cleaning up DB OK
Fetching notifications OK
Caching PeeringDB data OK

Output fro php -v :

PHP 7.2.14 (cli) (built: Jan 12 2019 12:47:33) ( NTS )
Copyright © 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright © 1998-2018 Zend Technologies
with Zend OPcache v7.2.14, Copyright © 1999-2018, by Zend Technologies

Is this a bug, any reason for concern?

Thank you


#2

You will still get notification in webui due to a bug, but you are ready to go without issues.

Just run daily and validate.


#3

Fix for the notification is merged now, run ./daily.sh to fix it (or just wait until it runs on its own)