Daily update

Looks like auto updates of LNMS not working in my case, my Libre is 1.52-70-gf3ba8947f now.
In config.php:
#$config[‘update’] = 0;

What can be the problem and how can I update my Libre?

Thank you in advance.


Have a look here:


Thank you for your reply. I wanted to try update lnms today but found that my Telegram notifications stopped. Test notifications is ok but from LNMS no notifications around couple days. I would like to fix it before I update LNMS. Could you tell me please how can I debug telegram notifications? I see problems on dashboard and I know that problem is present but I no see any notifications in my telegram.

Test transport for Telegram generates and successfully sends a message to the group it is configured to send to
No configuration or any settings have been changed
Deleted and reconfigured the transport method without any changes

Any ideas?

Hi Guys,
I have LNMS v. 1.52-70

May I update LNMS by using

su - librenms
git pull

commands or I should use some other way?
Thank you in advance.

This should be sufficiant, unless you completely disabled updates in LibreNMS config :

If you did disable updates, just re-enable them (release or master) and run ./daily.sh again.

I’ve tried to update my librenms to the latest version but looks like nothing changed -
librenms@lnms01:~$ ./daily.sh
Updating SQL-Schema OK
Cleaning up DB OK
Current version is 1.52-70. What should i do for updating my librenms?
Thank you in advance.

librenms@lnms01:~$ ./validate.php

Component Version
LibreNMS 1.52-70-gf3ba8947f
DB Schema 2019_05_30_225937_device_groups_rewrite (135)
PHP 7.2.19-0ubuntu0.18.04.1
MySQL 10.1.40-MariaDB-0ubuntu0.18.04.1
RRDTool 1.7.0


[OK] Composer Version: 2.0.0
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[WARN] Your install is over 24 hours out of date, last update: Sun, 23 Jun 2019 05:29:12 +0000
Make sure your daily.sh cron is running and run ./daily.sh by hand to see if there are any errors.
[WARN] Your local git contains modified files, this could prevent automatic updates.
You can fix this with ./scripts/github-remove
Modified Files:
[FAIL] We have found some files that are owned by a different user than librenms, this will stop you updating automatically and / or rrd files being updated causing graphs to fail.
sudo chown -R librenms:librenms /opt/librenms
sudo setfacl -d -m g::rwx /opt/librenms/rrd /opt/librenms/logs /opt/librenms/bootstrap/cache/ /opt/librenms/storage/
sudo chmod -R ug=rwX /opt/librenms/rrd /opt/librenms/logs /opt/librenms/bootstrap/cache/ /opt/librenms/storage/

I’ve tried git pull and after ./daily.sh and after this i got this -

$ ./validate.php

In PackageManifest.php line 122:

Undefined index: name


Component Version
LibreNMS 1.63-57-g0040f38d1
DB Schema Not Connected (0)
PHP 7.4.16
Python 3.6.8
RRDTool 1.7.0


[OK] Composer Version: 2.0.11
[OK] Dependencies up-to-date.

try to run daily once more. You may have missing dependancies. And according to your old ./validate.php, you also have right issues. Some files are not owned by librenms user. The fixes were given by validate.php.

We’ve updated php, mysql and changed configuration on nginx side + laravel and all these fixed my problem ))

1 Like

If you want to avoid these issue, I stringly suggest to keep updates running automatically (either stable or master, your choice). You’ll be notified whenever some requirement must be updated (like PHP, etc) and you’ll get enhancements from the community as soon as they are in the git repository.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.