Debug Traceroute not working-production.ERROR: The process "'/usr/bin/traceroute' '-q' '1' '-w' '1' '192.168.12.10'" exceeded the timeout of 60 seconds

Hi

Im getting the the following error in the librenms log for traceroute:

[2019-06-14 09:38:29] production.ERROR: The process “’/usr/bin/traceroute’ ‘-q’ ‘1’ ‘-w’ ‘1’ ‘10.110.47.12’” exceeded the timeout of 60 seconds. {“exception”:"[object] (Symfony\Component\Process\Exception\ProcessTimedOutException(code: 0): The process “’/usr/bin/traceroute’ ‘-q’ ‘1’ ‘-w’ ‘1’ ‘10.110.47.12’” exceeded the timeout of 60 seconds. at /opt/librenms/vendor/symfony/process/Process.php:1237)
[stacktrace]
#0 /opt/librenms/vendor/symfony/process/Process.php(416): Symfony\Component\Process\Process->checkTimeout()
#1 /opt/librenms/vendor/symfony/process/Process.php(235): Symfony\Component\Process\Process->wait()
#2 /opt/librenms/includes/functions.php(2169): Symfony\Component\Process\Process->run()
#3 /opt/librenms/includes/functions.php(2192): runTraceroute(Array)
#4 /opt/librenms/includes/polling/functions.inc.php(281): device_is_up(Array, true)
#5 /opt/librenms/poller.php(157): poll_device(Array, false)
#6 {main}

Has anyone come across this?

Thank

when i run the command ’/usr/bin/traceroute’ ‘-q’ ‘1’ ‘-w’ ‘1’ ‘10.110.47.12’”

it looks like the traceroute goes on for ever and does not stop after a certain amount of hops hence the timeout.

[email protected]:/opt/librenms/logs# traceroute -q 1 -w 1 10.110.47.12
traceroute to 10.110.47.12 (10.110.47.12), 64 hops max
1 198.18.2.129 0.093ms
2 192.168.1.99 19.082ms
3 192.57.7.2 20.485ms
4 192.168.16.3 20.086ms
5 *
6 *
7 *
8 *
9 *
10 *
11 *
12 *
13 *
14 *
15 *
16 *
17 *
18 *
19 *
20 *
21 *
22 *
23 *
24 *
25 *
26 *
27 *
28 *
29 *
30 *
31 *
32 *
33 *
34 *
35 *
36 *
37 *
38 *
39 *
40 *
41 *
42 *
43 *
44 *
45 *
46 *
47 *
48 *
49 *
50 *
51 *
52 *
53 *
54 *
55 *
56 *
57 *
58 *
59 *
60 *
61 *
62 *
^C

Some more info when I look at the syntax available for the traceroute command:

traceroute --help
Usage: traceroute [OPTION…] HOST
Print the route packets trace to network host.

-f, --first-hop=NUM set initial hop distance, i.e., time-to-live
-g, --gateways=GATES list of gateways for loose source routing
-I, --icmp use ICMP ECHO as probe
-m, --max-hop=NUM set maximal hop count (default: 64)
-M, --type=METHOD use METHOD (icmp' orudp’) for traceroute
operations, defaulting to `udp’
-p, --port=PORT use destination PORT port (default: 33434)
-q, --tries=NUM send NUM probe packets per hop (default: 3)
–resolve-hostnames resolve hostnames
-t, --tos=NUM set type of service (TOS) to NUM
-w, --wait=NUM wait NUM seconds for response (default: 3)
-?, --help give this help list
–usage give a short usage message
-V, --version print program version

The default amount of hops the traceoute will run for is 64 unless specified when I tested how long it would take to run a traceroute for the default amount of hops it took 60 seconds to run 58 hops, hence the timeout.

Can the code be finetuned to set the maximum amount of hops to be 30 and not the default of 64.

Thanks

Is it possible to set the parameters for the traceroute in config.php file?

1 Like