Devices list stuck at loading


#1

====================================

Component Version
LibreNMS 1.48.1-70-g2eac72d34
DB Schema 2019_01_16_195644_add_vrf_id_and_bgpLocalAs (131)
PHP 7.2.15-1+0~20190209065123.16+stretch~1.gbp3ad8c0
MySQL 10.1.37-MariaDB-0+deb9u1
RRDTool 1.6.0
SNMP NET-SNMP 5.7.3

====================================

[OK] Composer Version: 1.2.2
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct

So, I just updated the LibreNMS to the lastest version, and now if I want to list the deives on WebGUI, it is stuck at “Loading…”

I have found these on /librenms/devices/debug page:
image

If I list the Ports or Health menu, everything is there, and from there I can reach the devices details pages.
./daily.php ran with no problem, also I restarted the server multiple times, just in case.

Any idea?

Thank you!


#2

If you put $config['force_ip_to_sysname'] = false; at the end of your config.php, does it make a difference?


#3

$config[‘force_ip_to_sysname’] = false;
$config[‘force_hostname_to_sysname’] = false;

Both was true, but did not help.


#4

When you load the page, anything to note in your librenms.log file ?


#5

Nothing new (lots of poller and some discovery log), only the access.log updating when I reload or browsing on the webGUI.


#6

If you create a new group like this

image

Then you go Device -> Device Groups -> test

Does it load?

Also try Basic list

image


#7

Thank you for your effort to try to help me!

I already use groups, but I created a test one based on your manual. The result is the same under every groups; Loading…
Of course if I load here the Graphs, I have graphs.

Also for example under Health, the webGUI very responsive and fast, so I do not think it is a performance issue.


#8

I really hate that Component code…


#9

I installed a brand new Debian server with clean LibreNMS, same issue. :frowning:


#10

Do you have any symbols or odd characters in any of your device names?

what if its a clean install, the page loads , and if you add 1 device more 2 device more etc…


#11

I just did it.
I installed a Debian server from scratch, just as before when LibreNMS was worked. I installed the LibreNMS as earlier, but I also followed the installation document, and add 1 device only with IP.

I’m behind a Proxy, and I saw some errors, but I do not think this cause this:

./scripts/composer_wrapper.php install --no-dev
Error: Failed to download installer signature from https://composer.github.io/installer.sig
Do not run Composer as root/super user! See https://getcomposer.org/root for details
LibreNMS\ComposerHelper::preInstall
Loading composer repositories with package information
Installing dependencies from lock file
Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.
Package operations: 0 installs, 0 updates, 50 removals

  • Removing webmozart/assert (1.4.0)
  • Removing theseer/tokenizer (1.1.0)
  • Removing symfony/filesystem (v4.2.3)
  • Removing squizlabs/php_codesniffer (2.9.2)
  • Removing seld/phar-utils (1.0.1)
  • Removing seld/jsonlint (1.7.1)
  • Removing sebastian/version (2.0.1)
  • Removing sebastian/resource-operations (2.0.1)
  • Removing sebastian/recursion-context (3.0.0)
  • Removing sebastian/object-reflector (1.1.1)
  • Removing sebastian/object-enumerator (3.0.3)
  • Removing sebastian/global-state (2.0.0)
  • Removing sebastian/exporter (3.1.0)
  • Removing sebastian/environment (4.1.0)
  • Removing sebastian/diff (3.0.2)
  • Removing sebastian/comparator (3.0.2)
  • Removing sebastian/code-unit-reverse-lookup (1.0.1)
  • Removing phpunit/phpunit (7.5.4)
  • Removing phpunit/php-token-stream (3.0.1)
  • Removing phpunit/php-timer (2.0.0)
  • Removing phpunit/php-text-template (1.2.1)
  • Removing phpunit/php-file-iterator (2.0.2)
  • Removing phpunit/php-code-coverage (6.1.4)
  • Removing phpspec/prophecy (1.8.0)
  • Removing phpdocumentor/type-resolver (0.4.0)
  • Removing phpdocumentor/reflection-docblock (4.3.0)
  • Removing phpdocumentor/reflection-common (1.0.1)
  • Removing phar-io/version (2.0.1)
  • Removing phar-io/manifest (1.0.3)
  • Removing nunomaduro/collision (v2.1.1)
  • Removing myclabs/deep-copy (1.8.1)
  • Removing mockery/mockery (1.2.2)
  • Removing maximebf/debugbar (v1.15.0)
  • Removing laravel/dusk (v5.0.0)
  • Removing justinrainbow/json-schema (5.2.8)
  • Removing jakub-onderka/php-parallel-lint (v1.0.0)
  • Removing hamcrest/hamcrest-php (v2.0.0)
  • Removing fzaninotto/faker (v1.8.0)
  • Removing filp/whoops (2.3.1)
  • Removing facebook/webdriver (1.6.0)
  • Removing doctrine/instantiator (1.1.0)
  • Removing composer/xdebug-handler (1.3.2)
  • Removing composer/spdx-licenses (1.5.0)
  • Removing composer/semver (1.4.2)
  • Removing composer/composer (1.8.4)
  • Removing composer/ca-bundle (1.1.4)
  • Removing beyondcode/laravel-dump-server (1.2.2)
  • Removing barryvdh/reflection-docblock (v2.0.6)
  • Removing barryvdh/laravel-ide-helper (v2.5.3)
  • Removing barryvdh/laravel-debugbar (v3.2.2)
    Generating optimized autoload files
    Illuminate\Foundation\ComposerScripts::postAutoloadDump
    @php artisan package:discover --ansi
    Discovered Package: fideloper/proxy
    Discovered Package: laravel/laravel
    Discovered Package: laravel/nexmo-notification-channel
    Discovered Package: laravel/slack-notification-channel
    Discovered Package: laravel/tinker
    Discovered Package: nesbot/carbon
    Discovered Package: oriceon/toastr-5-laravel
    Package manifest generated successfully.
    LibreNMS\ComposerHelper::postInstall
    Illuminate\Foundation\ComposerScripts::postInstall

./validate.php
====================================
Component | Version
--------- | -------
LibreNMS | 1.48.1-85-gee7605742
DB Schema | 2019_02_10_220000_add_dates_to_fdb (132)
PHP | 7.2.15-1+0~20190209065123.16+stretch~1.gbp3ad8c0
MySQL | 10.1.37-MariaDB-0+deb9u1
RRDTool | 1.6.0
SNMP | NET-SNMP 5.7.3
====================================
[OK] Composer Version: 1.8.4
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[WARN] Some devices have not been polled in the last 5 minutes. You may have performance issues.
[FIX]:
Check your poll log and see: http://docs.librenms.org/Support/Performance/
Devices:
172.20.47.36
[FAIL] /var/run/rrdcached.sock doesn’t appear to exist, rrdcached test failed
[WARN] Your local git contains modified files, this could prevent automatic updates.
[FIX]:
You can fix this with ./scripts/github-remove
Modified Files:
bootstrap/cache/.gitignore
logs/.gitignore
rrd/.gitignore
storage/app/.gitignore
storage/app/public/.gitignore
storage/debugbar/.gitignore
storage/framework/cache/.gitignore
storage/framework/cache/data/.gitignore
storage/framework/sessions/.gitignore
storage/framework/testing/.gitignore
storage/framework/views/.gitignore
storage/logs/.gitignore


#12

Check those


#13

Failed to download installer signature from…

Like I said, the server behind proxy, so this is not easy to resolve, although with wget I can download this file. And I’m not sure, if this cause the problem.

[FAIL] /var/run/rrdcached.sock doesn’t appear to exist, rrdcached test failed

This is a test, clean server. The LibreNMS in production (where I have the same issue) has no RRDCache problem, just the “signature file” ones.


#14

Composer wrapper allow proxy if you have set it up in your config.php https://docs.librenms.org/Support/Configuration/#proxy-support

In the test server, remove the rrdcached config.

How many devices you added to test env? Do you still get the dev console errors?


#15

I found the problem!

In config.php I used this option:
$config['base_url'] = "/librenms/";

This worked until version 1.40, I think. And maybe then a bug fixed?!

So now there is no isse, if I comment this line out, or use it this way, which was the correct one at the first place probably:
#$config['base_url'] = "http://X.X.X.X/librenms/";

Thank you for your support and the ideas! :wink: