Devices show in maintenance but no maintenance is current (Can I downgrade?)

I’ve been having issues on and off with recurring maintenance for a while and everything was working fine until the latest update to 1.65.1. Currently I have a couple of recurring maintenance schedules set and it seems like once the maintenance schedule starts it does not ever end. Here is a screenshot of my current maintenance schedules

Here is what they look like in mysql:
MariaDB [librenms]> select * from alert_schedule;
| schedule_id | recurring | start | end | recurring_day | title | notes |
| 26 | 0 | 2020-06-25 09:14:00 | 2020-07-10 08:59:00 | NULL | Noisy things | |
| 35 | 1 | 2020-07-14 20:57:00 | 2021-01-01 04:59:00 | 1,2,3,4,5 | Weekly | |
| 36 | 1 | 2020-07-14 04:00:00 | 2020-12-31 12:05:00 | 1,2,3,4,5,6 | midnights | |

I notice the timestamps in the database appear to be UTC but I do not think this is the cause of the issue.

This is the one that is stuck right now

These are mapped to groups I have created and every device in the groups listed currently shows that they are in maintenance, I’ve also tested blocking device IPs in iptables on the server and librenms never creates an alert. I’ve triple checked that the Devices up/down alert rule is active and it is:

I noticed this yesterday and figured it was due to the update and deleted then recreated my recurring maintenance schedules which took them out of maintenance, however when checking this morning it appears the devices are still in maintenance despite no maintenance schedule being current. Is there anything I can do to fix this or any possible way to downgrade to the previous release so I can have the recurring maintenance working again?


Component Version
LibreNMS 1.65.1
DB Schema 2020_06_23_00522_alter_availability_perc_column (170)
PHP 7.3.10
Python 3.6.8
MySQL 5.5.64-MariaDB
RRDTool 1.7.1

[OK] Composer Version: 1.10.8
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[WARN] IPv6 is disabled on your server, you will not be able to add IPv6 devices.

Well I recreated the schedules and all the devices that were in maintenance are now not in maintenance. Now it’s time for the maintenance schedule to start and none of them are in maintenance now… I have no idea what to even check to see what is wrong at this point. This is great…

Devices that should be in maintenance are not though. Anyone, any help?? I’m not sure what to look at next at all…

I created a non-recurring maintenance schedule for today to last until tomorrow at 7am with exactly the same device groups in it and it works just fine. Seems that recurring is just broken again which seems to happen every update, I’m starting to wonder if it’s just me and an issue with my install or if recurring maintenance just isn’t commonly used.

Librenms is the best open source monitor I saw. It’s the good one! Great job!

I have just the same problem like @scristopher, same versions and same problem, only with recurring maintenance schedulers. Anyone knows if there are some bugs inside that? Any idea? I just checked timezone of all staff (MariaBD, linux, php…). Also I try to apply the chedule maintenance rule only to one device and issue occurs anyway.

Thanks in advance!

Now I’m down to just creating daily maintenance because clearly recurring just doesn’t work anymore. I really wish I could just downgrade, but need some information on how I would do so and to know if it’s even possible.

I just ended up creating maintenance for single days and updating the dates via a mysql update on the alert schedule table via cron daily. I guess this is how recurring maintenance is going to work and be stable for me now and I’m actually fine with that because it’s super annoying to have it just stop working and not know about it not working until someone else notifies me about it or I find out myself at 3am.

Hello, We have same problem since we upgraded. Did you find a solution since last year ? :sweat_smile:

This topic was automatically closed 730 days after the last reply. New replies are no longer allowed.