Discovery & Ignored ports

Does discovery cron for all hosts removed the selections you’ve made on individual ports?

We had some ports set to ignore on a couple of devices but when we re-enabled the discovery cron for all hosts it seems to wiped those settings but kept the speed overrides?

is this normal or a bug?

We need a little more info here.

Where/how did you mark the ports as disabled?

Did they display as disabled in the webui after you changed the setting and after you “re-enabled” the cron?

Post the output of ./validate.php too.

We marked them as ignore in the device setting page under ports.

They were set that way for days up until the day I reenabled the cron, the following day we started seeing alerts again and noticed that the checkbox next to ignore was now unchecked on all devices.


Component Version
LibreNMS 1.30.01-100-g30c1b79
DB Schema 204
PHP 7.1.6
MySQL 10.1.25-MariaDB
RRDTool 1.7.0

[OK] Database connection successful
[OK] Database schema correct
[WARN] Your install is out of date, last update: Wed, 23 Aug 2017 18:29:40 +0000

Perhaps the port indexes changed or something. How long was the discovery cron not running?

Hmm… over 2 weeks easily.

edit: dug up the logs, 28 days

I’d say try setting it again and see what happens. Do a poller and discovery debug run and save the output to compare to later if you have issues again.