Duplicate data in OSPF discovery

In my device OSPF data is shown as

SNMP walk in OSPF neighbor table from terminal

/opt/librenms $ snmpbulkwalk -v2c -c public -M $PWD/mibs -OQXUt -Os OSPF-MIB::ospfNbrEntry
ospfNbrIpAddr[][0] =
ospfNbrAddressLessIndex[][0] = 0
ospfNbrRtrId[][0] =
ospfNbrOptions[][0] = 66
ospfNbrPriority[][0] = 1
ospfNbrState[][0] = full
ospfNbrEvents[][0] = 6
ospfNbrLsRetransQLen[][0] = 0
ospfNbmaNbrStatus[][0] = active
ospfNbmaNbrPermanence[][0] = dynamic
ospfNbrHelloSuppressed[][0] = false
ospfNbrRestartHelperStatus[][0] = notHelping
ospfNbrRestartHelperAge[][0] = 0
ospfNbrRestartHelperExitReason[][0] = none

It looks like the data is being somehow duplicated in the browser.

Validate o/p

/opt/librenms $ ./validate.php 
Component | Version
--------- | -------
LibreNMS  | 22.2.1
DB Schema | 2021_25_01_0129_isis_adjacencies_nullable (234)
PHP       | 7.4.28
Python    | 3.9.7
MySQL     | 10.4.14-MariaDB-1:10.4.14+maria~focal
RRDTool   | 1.7.2
SNMP      | 5.9.1

[OK]    Installed from the official Docker image; no Composer required
[OK]    Database connection successful
[FAIL]  Database: incorrect column (notifications/datetime)
[FAIL]  Database: incorrect column (users/created_at)
[FAIL]  We have detected that your database schema may be wrong
	Run the following SQL statements to fix it
	SQL Statements:
	 SET TIME_ZONE='+00:00';
	 ALTER TABLE `notifications` CHANGE `datetime` `datetime` timestamp NOT NULL DEFAULT '1970-01-02 00:00:00' ;
	 ALTER TABLE `users` CHANGE `created_at` `created_at` timestamp NOT NULL DEFAULT '1970-01-02 00:00:01' ;
[WARN]  IPv6 is disabled on your server, you will not be able to add IPv6 devices.
[WARN]  Updates are managed through the official Docker image

Discovery o/p: Untitled - LibreNMS

Poll o/p: Untitled - LibreNMS

I had that happen to me a few months back. Not sure what caused it though. Check the database to see if there are actual duplicates.

I just deleted all the rows and let it rediscover.

Looks like Deleting the device and re-adding it again does the trick. Thanks a lot.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.