Email alert not working


I have setup smtp configuration and transports. When I click “test transport” I get a nice test email.

I have configured the default “device down” alert rule, and also a custom alert rule, with the Email Transport and downed a device.
The alert rule is triggered (red) but i am not getting any kind of email out of it.

What is next to troubleshoot?

“Global Settings” → “Alerting”: Check, that every option/field is configured/set correctly;

Can’t seem to spot anything wrong

Check the logfiles of every process that is in the line of communication.

I run Librenms in a docker container.
I found /data/logs/daily.log and librenms.log but neither show any interesting information regarding this issue.

Can You confirm, that LibreNMS actually sent out a message? If not, why. If yes, where did it go? What are the next steps in the communication chain?

Sorry i’ve just started using LibreNMS and cannot seem to find any log files and debugging options to show me this information.

My mailserver does not receive any mail send attempts from Librenms.

I configured a Telegram transport (which works with the test transport button) but i have the exact same issue. Also no message on device failure.

The system randomly sent 2 emails yesterday about a rebooted device and the recovery of it
Rebooting that device again right now no longer generates any mails.

“Sensor over limit” rule seems to work. Device up/down, Device rebooted or port up/down rules don’t.

I ran an Alert capture on the devices.
All of them show;

Rule name: Device Down! Due to no ICMP response.
Alert rule: macros.device_down = 1 AND devices.status_reason = “icmp”
Alert query: SELECT * FROM devices WHERE (devices.device_id = ?) AND (devices.status = 0 && (devices.disabled = 0 && devices.ignore = 0)) = 1 AND devices.status_reason = “icmp”
Rule match: no match

But I do get Alerts triggered in the GUI when this device is down. Just nothing via Transports

So, You DO GET messages, that are triggerd by alarms? Then check/test the timing of the alerts. Try this:

set “Max Alerts” to 1, “Delay” to 0 and “Interval” to 0

Delay 0 should fire a message the instant LibreNMS finds out about it.
Max Alerts 1 and Interval 0 stops LibreNMS from flodding You with messages.

Does that generate the expected messages?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.