Enable influxdb support in LibreNMS

hallo , i have problem i want to enable influxdb support in libreNms then i want to use grafana ,my question how can i do that _
i install the influxdb and grafana and librenms everything work will but i want to connect
i saw this link and i add waht this writen in config.php file for librenms :::::
but did not occure anything .
i need help how we can do that

You need to set those options, we can’t tell you what they are specifically as they can be specific to your setup but the InfluxDB docs should cover what port it runs on and how to create a database within InfluxDB.

Once the details are correct then you should start seeing data in InfluxDB within 5 minutes.

i follow the steps but my question , i will paste the instruction in http://docs.librenms.org/Extensions/InfluxDB/
in config.php from librenms right ?

Do you mein , that first i will creat databease in influxdb second name it librenms
username librenms and password 123
then i will edit nano /opt/linrenms/config.php
fourth i add the instruction in link _
that ok _ or not and what i muss insert
i use this command
creat datebase librenms ist that enough _

  1. Yes create the database.

  2. You can set what ever username / password you like or not use auth - you need to read the docs for Influx here, this isn’t a LibreNMS thing

yes , i know but my problem how can my database in influxdb read the date from librenms
, in the link they write ,that Librenms write the data in influxdb but wenn i add the code they can not write .and
http://localhost:8086 —_page is not found so what the solution

You don’t read data from LibreNMS, we send the data to InfluxDB if it’s properly configured. If you can’t get to the interface to Influx then it sounds like you’ve not set that up, go through the influx docs to get a working install before you try and configure LibreNMS to send data to it.

thank you , everything is okey , now i fix the problem and i can show my graphs in grafana

Hello selma
Tell me please how you did to install influxdb because i already librenms and i want to install influxdb for the same principle as you
Did you follow the tutorial in the documentation of influx db ??
thank you

1 Like

I think it was essy just follow rhe instruction
Librenms installion
Influxdb installion
Creat DB
Play with configurationfile from librenms redirect the output to librenms

I followed the instructions after installation of influxdb,
After installation of influxdb I create the database like this
$ influx
Connected to http://localhost:8086 version 0.13
InfluxDB shell version: 0.13

GRANT ALL ON librenms_db TO librenms
GRANT READ ON librenms_db TO grafana

after Enable authentication in the [http]
enabled = true
bind-address = “:8086”
auth-enabled = true
log-enabled = true
write-tracing = false
pprof-enabled = false
https-enabled = false
https-certificate = “/etc/ssl/influxdb.pem”

but after all this when i go in the page to use librenms they say me does not work

What does this mean? What page?

hi @laf
this page
When I do not use the influxdb databases and do this :

$config[‘influxdb’][‘enable’]= false;
i have this

When I want to use the database Influxdb
$config[‘influxdb’][‘enable’]= true;

i have this page

It is not me who install librenms it is my colegue who works with the rrd bases and I just wanted to change the configuration to use it with Influxdb bases and I am a little los
If you can help me

Seems like you’ve made a mistake in config.php - or you aren’t running php 5.5 or above.

Run php -ln /opt/librenms/config.php