Enabling Email alerts return "Error: No config item"

In Global Settings > Alerting Settings > Email options I try to Enable email alerting and it returns Error: No config item.

validate.php comes back clean.

I updated everything I could

image

This happens in both Chrome and Firefox.

Not sure what else to check.

You are missing some data in your database.

Try running this in the librenms directory:

php artisan db:seed --class=DefaultConfigSeeder

Got a couple errors, i’m pretty rubbish with Linux so it’s possible I did it wrong.

image

You did it ok, but it is intended to be run on a fully empty database, so that is why you got an error.
Try it now.

Same errors.

I meant try changing the setting in the webui.

Yeah sorry, it still isn’t working. Same error.

If I understand you correctly, in the webui, when you change the setting “Enable email alerting” from off to on you receive the error?

Are the rest of the settings under mail filled in correctly? for example:
How to deliver mail:
From name:
From email address:
Use HTML emails:

Correct

“No config item” means an entry is missing from his config table in the database.

@Matt_Fogleman I’ve updated the seeders. Run ./daily.sh then try to run the seed again. It should do the job now.

Same error unfortunately.

No error on the seeder, you mean the webui?

Check your database:

select * from config where config_name like '%mail%';

Hello,

unfortunately I am facing the exact same issue as mentioned by OP. I also tried all the steps described in this thread but did not get it to work.
Any further ideas what this could be? A list of things I tried:

  • Rebuilding the database from scratch
  • Running the ConfigSeeder again
  • Running ./daily.sh
  • ./validate.php is clean with no errors

This is a fresh install on Ubuntu 18.04 using only the provided guide from the docs

same to me too. It started like 4 days ago

is there any fix for this?

Yeah sorry, seeder ran ok but webui still returns an error.

I’m in the same boat too.

Similar issue here. I built a test install on some junky hardware about three weeks ago, wanted try importing a few things from observium and test out alerting, no issues related to email. Found some better hardware and completed a fresh install on Friday and have the same “ERROR: no config item” when toggling ‘enable email alerting’ as well as when I try and switch the Geocoding engine away from the default Google Maps. Same error when I toggle “Enable Dynamic graphs.” Both installs were on Ubuntu 18.04 server.

Ok, found the issue. There was a missing config item in the default seeder. Run ./daily.sh and the seeder again.

php artisan db:seed --class=DefaultConfigSeeder
1 Like