Error install: plugin - vlans-compare

When I try to install the plugin with the command: ./lnms plugin:add dmbokhan/vlans-compare
I get the error message :

Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.
Problem 1
-Root composer.json requires dmbokhan/vlans-compare * -> satisfiable by dmbokhan/vlans-compare[1.0.0, 1.0.1, 1.0.2, 1.0.3].
-dmbokhan/vlans-compare[1.0.0, ..., 1.0.3] require librenms/librenms ^23.9.1 -> satisfiable by librenms/librenms[23.9.1, 23.10.0, 23.11.0] from composer repo ( but librenms/librenms is the root package and cannot be modified. See for details and assistance.
Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.
You can also try re-running composer require with an explicit version constraint, e.g. "composer require dmbokhan/vlans-compare:*" to figure out if any version is installable, or "composer require dmbokhan/vlans-compare:^2.1" if you know which you need.
Installation failed, reverting ./composer.json and ./composer.lock to their original _content.

I can’t find a solution, I think I’m missing a package dependency?
Or is it possible to install this plugin manually ? gitclone / copy files in correct directories ?
Thanks for your help

Hi lynch4fr!

I just saw your message here. It was fixed and I answered you on GitHub. Error install plugin : LibreNMS\ComposerHelper::preUpdate · Issue #3 · dmbokhan/vlans-compare · GitHub

1 Like