Error installating Librenms on Ubuntu 18.04

Hi! I have tried couple of links but didnt get success in the installation.Now I tried the official link but same issue.
I am using Ubuntu 18.04.
Below is my installation error.

su - librenms
$ ./scripts/composer_wrapper.php install --no-dev
> LibreNMS\ComposerHelper::preInstall
Loading composer repositories with package information
Installing dependencies from lock file
Package operations: 80 installs, 0 updates, 0 removals
As there is no 'unzip' command installed zip files are being unpacked using the PHP zip extension.
This may cause invalid reports of corrupted archives. Besides, any UNIX permissions (e.g. executable) defined in the archives will be lost.
Installing 'unzip' may remediate them.
  - Installing symfony/dotenv (v3.4.39): Downloading (100%)         
  - Installing amenadiel/jpgraph (3.6.21): Downloading (100%)         
  - Installing clue/socket-raw (v1.4.1): Downloading (100%)         
  - Installing dapphp/radius (2.5.4): Downloading (100%)         
  - Installing symfony/polyfill-ctype (v1.15.0): Downloading (100%)         
  - Installing phpoption/phpoption (1.7.3): Downloading (100%)         
  - Installing vlucas/phpdotenv (v3.6.2): Downloading (100%)         
  - Installing symfony/css-selector (v4.4.7): Downloading (100%)         
  - Installing tijsverkoyen/css-to-inline-styles (2.2.2): Downloading (100%)         
  - Installing symfony/polyfill-php72 (v1.15.0): Downloading (100%)         
  - Installing symfony/polyfill-mbstring (v1.15.0): Downloading (100%)         
  - Installing symfony/var-dumper (v4.4.7): Downloading (100%)         
  - Installing symfony/routing (v4.4.7): Downloading (100%)         
  - Installing symfony/process (v4.4.7): Downloading (100%)         
  - Installing symfony/polyfill-php73 (v1.15.0): Downloading (100%)         
  - Installing symfony/polyfill-intl-idn (v1.15.0): Downloading (100%)         
  - Installing symfony/mime (v4.4.7): Downloading (100%)         
  - Installing symfony/http-foundation (v4.4.7): Downloading (100%)         
  - Installing symfony/event-dispatcher-contracts (v1.1.7): Downloading (100%)         
  - Installing symfony/event-dispatcher (v4.4.7): Downloading (100%)         
  - Installing psr/log (1.1.3): Downloading (100%)         
  - Installing symfony/debug (v4.4.7): Downloading (100%)         
  - Installing symfony/error-handler (v4.4.7): Downloading (100%)         
  - Installing symfony/http-kernel (v4.4.7): Downloading (100%)         
  - Installing symfony/finder (v4.4.7): Downloading (100%)         
  - Installing psr/container (1.0.0): Downloading (100%)         
  - Installing symfony/service-contracts (v1.1.8): Downloading (100%)         
  - Installing symfony/console (v4.4.7): Downloading (100%)         
  - Installing symfony/polyfill-iconv (v1.15.0): Downloading (100%)         
  - Installing doctrine/lexer (1.0.2): Downloading (100%)         
  - Installing egulias/email-validator (2.1.17): Downloading (100%)         
  - Installing swiftmailer/swiftmailer (v6.2.3): Downloading (100%)         
  - Installing paragonie/random_compat (v9.99.99): Downloading (100%)         
  - Installing ramsey/uuid (3.9.3): Downloading (100%)         
  - Installing psr/simple-cache (1.0.1): Downloading (100%)         
  - Installing opis/closure (3.5.1): Downloading (100%)         
  - Installing symfony/translation-contracts (v1.1.7): Downloading (100%)         
  - Installing symfony/translation (v4.4.7): Downloading (100%)         
  - Installing nesbot/carbon (2.32.2): Downloading (100%)         
  - Installing monolog/monolog (1.25.3): Downloading (100%)         
  - Installing league/flysystem (1.0.66): Downloading (100%)         
  - Installing erusev/parsedown (1.7.4): Downloading (100%)         
  - Installing dragonmantank/cron-expression (v2.3.0): Downloading (100%)         
  - Installing doctrine/inflector (1.3.1): Downloading (100%)         
  - Installing laravel/framework (v5.8.37): Downloading (100%)         
  - Installing darkghosthunter/larapoke (v3.1.0): Downloading (100%)         
  - Installing doctrine/event-manager (1.1.0): Downloading (100%)         
  - Installing doctrine/cache (1.10.0): Downloading (100%)         
  - Installing doctrine/dbal (v2.9.3): Downloading (100%)         
  - Installing easybook/geshi (v1.0.8.19): Downloading (100%)         
  - Installing ezyang/htmlpurifier (v4.12.0): Downloading (100%)         
  - Installing fico7489/laravel-pivot (3.0.4): Downloading (100%)         
  - Installing guzzlehttp/promises (v1.3.1): Downloading (100%)         
  - Installing ralouphie/getallheaders (3.0.3): Downloading (100%)         
  - Installing psr/http-message (1.0.1): Downloading (100%)         
  - Installing guzzlehttp/psr7 (1.6.1): Downloading (100%)         
  - Installing guzzlehttp/guzzle (6.5.2): Downloading (100%)         
  - Installing influxdb/influxdb-php (1.15.0): Downloading (100%)         
  - Installing jakub-onderka/php-console-color (v0.2): Downloading (100%)         
  - Installing nikic/php-parser (v4.3.0): Downloading (100%)         
  - Installing jakub-onderka/php-console-highlighter (v0.4): Downloading (100%)         
  - Installing dnoegel/php-xdg-base-dir (v0.1.1): Downloading (100%)         
  - Installing psy/psysh (v0.9.12): Downloading (100%)         
  - Installing laravel/tinker (v1.0.10): Downloading (100%)         
  - Installing fideloper/proxy (4.3.0): Downloading (100%)         
  - Installing laravel/laravel (v5.8.35): Downloading (100%)         
  - Installing martinlindhe/laravel-vue-i18n-generator (0.1.46): Downloading (100%)         
  - Installing oriceon/toastr-5-laravel (dev-master 8a03502): Downloading (100%)         
  - Installing pear/console_color2 (0.1.2): Downloading (100%)         
  - Installing pear/console_table (v1.3.1): Downloading (100%)         
  - Installing phpseclib/phpseclib (2.0.26): Downloading (100%)         
  - Installing php-amqplib/php-amqplib (v2.11.1): Downloading (100%)         
  - Installing phpmailer/phpmailer (v6.1.5): Downloading (100%)         
  - Installing rmccue/requests (v1.7.0): Downloading (100%)         
  - Installing spatie/laravel-cors (1.3.3): Downloading (100%)         
  - Installing symfony/yaml (v4.4.7): Downloading (100%)         
  - Installing tecnickcom/tcpdf (6.2.26): Downloading (100%)         
  - Installing tightenco/ziggy (v0.7.1): Downloading (100%)         
  - Installing wpb/string-blade-compiler (3.8.x-dev b3e340b): Downloading (100%)         
  - Installing xjtuwangke/passwordhash (dev-master a7bcd97): Downloading (100%)         
Package jakub-onderka/php-console-color is abandoned, you should avoid using it. Use php-parallel-lint/php-console-color instead.
Package jakub-onderka/php-console-highlighter is abandoned, you should avoid using it. Use php-parallel-lint/php-console-highlighter instead.
Package spatie/laravel-cors is abandoned, you should avoid using it. Use laravel/framework instead.
Generating optimized autoload files
Deprecation Notice: Class HTMLPurifier_Language_en_x_test located in ./vendor/ezyang/htmlpurifier/library/HTMLPurifier/Language/classes/en-x-test.php does not comply with psr-0 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///opt/librenms/composer.phar/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Crypt_CHAP_MD5 located in ./vendor/dapphp/radius/lib/Pear_CHAP.php does not comply with psr-0 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///opt/librenms/composer.phar/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Crypt_CHAP_MSv1 located in ./vendor/dapphp/radius/lib/Pear_CHAP.php does not comply with psr-0 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///opt/librenms/composer.phar/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Crypt_CHAP_MSv2 located in ./vendor/dapphp/radius/lib/Pear_CHAP.php does not comply with psr-0 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///opt/librenms/composer.phar/src/Composer/Autoload/ClassMapGenerator.php:201
> Illuminate\Foundation\ComposerScripts::postAutoloadDump
> @php artisan package:discover --ansi
Discovered Package: darkghosthunter/larapoke
Discovered Package: fideloper/proxy
Discovered Package: laravel/laravel
Discovered Package: laravel/tinker
Discovered Package: martinlindhe/laravel-vue-i18n-generator
Discovered Package: nesbot/carbon
Discovered Package: oriceon/toastr-5-laravel
Discovered Package: spatie/laravel-cors
Discovered Package: tightenco/ziggy
Package manifest generated successfully.
26 packages you are using are looking for funding.
Use the `composer fund` command to find out more!
> LibreNMS\ComposerHelper::postInstall
Application key set successfully.
> Illuminate\Foundation\ComposerScripts::postInstall
> @php artisan vue-i18n:generate --multi-locales --format=umd
> scripts/check_requirements.py || pip3 install -r requirements.txt || :slight_smile:

Thanks for looking into this.

Hi,

have you installed the required packages first?

Hi!
Yes.
This is the last guide I followed.
https://docs.librenms.org/Installation/Installation-Ubuntu-1804-Apache/

seems unzip is not installed

[https://www.scaleway.com/en/docs/setup-librenms-to-monitor-infrastructure/]
It starts with the follow issue.
The error is
Package jakub-onderka/php-console-color is abandoned, you should avoid using it. Use php-parallel-lint/php-console-color instead.
Package jakub-onderka/php-console-highlighter is abandoned, you should avoid using it. Use php-parallel-lint/php-console-highlighter instead.
Package spatie/laravel-cors is abandoned, you should avoid using it. Use laravel/framework instead.
Generating optimized autoload files
Deprecation Notice: Class HTMLPurifier_Language_en_x_test located in ./vendor/ezyang/htmlpurifier/library/HTMLPurifier/Language/classes/en-x-test.php does not comply with psr-0 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///opt/librenms/composer.phar/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Crypt_CHAP_MD5 located in ./vendor/dapphp/radius/lib/Pear_CHAP.php does not comply with psr-0 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///opt/librenms/composer.phar/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Crypt_CHAP_MSv1 located in ./vendor/dapphp/radius/lib/Pear_CHAP.php does not comply with psr-0 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///opt/librenms/composer.phar/src/Composer/Autoload/ClassMapGenerator.php:201
Deprecation Notice: Class Crypt_CHAP_MSv2 located in ./vendor/dapphp/radius/lib/Pear_CHAP.php does not comply with psr-0 autoloading standard. It will not autoload anymore in Composer v2.0. in phar:///opt/librenms/composer.phar/src/Composer/Autoload/ClassMapGenerator.php:201

and in the last its this.
Use the composer fund command to find out more!

LibreNMS\ComposerHelper::postInstall
Application key set successfully.
Illuminate\Foundation\ComposerScripts::postInstall
@php artisan vue-i18n:generate --multi-locales --format=umd
scripts/check_requirements.py || pip3 install -r requirements.txt || :
$ exit
[email protected]:/opt# locate requirements.txt
/opt/librenms/requirements.txt
/opt/librenms/vendor/influxdb/influxdb-php/ansible/requirements.txt
/usr/share/doc/python-setuptools/requirements.txt
I looked for these requirements.txt and run pip3 install for any package mentioned but still the same error.

Dude, I’ve readed your post just when I woke up this morning, and was very soon :slight_smile:

Your install is already done.

Those are just a few warnings (that will be fixed at some time) but your installation is done and should be almost ready to start working.

yes I am in. Thanks. Its working. Time to explorer how can I make interface traffic graph which I had issue with Cacti as it was not showing the correct values.