Fail: Cannot connect to rrdcached instance - and graphs not showing

Hi I really hope someone will help me.

I had an old Docker that tended to crash randomly .
So last week I downloaded the new docker from Dockerhub (link
Configured it as pr. old Docker configuration only change is the name (old: Librenms new: Librenms2021)

Ran the cleanup DB tasks and it seems to work. But there is no graphs showing:

In the RRD folder for DNS. Google:
/data/rrd/$ ls
availability-2592000.rrd availability-86400.rrd poller-perf.rrd
availability-31536000.rrd ping-perf.rrd
availability-604800.rrd poller-perf-availability.rrd

Librenms2021:/opt/librenms$ ./validate.php

Component Version
LibreNMS 21.6.0
DB Schema 2021_25_01_0127_create_isis_adjacencies_table (210)
PHP 7.4.19
Python 3.8.10
MySQL 10.4.12-MariaDB-1:10.4.12+maria~bionic
RRDTool 1.7.2

[OK] Installed from package; no Composer required
[OK] Database connection successful
[OK] Database schema correct
[WARN] IPv6 is disabled on your server, you will not be able to add IPv6 devices.
[FAIL] Cannot connect to rrdcached instance
[WARN] Non-git install, updates are manual or from package


Have a look in includes/ for examples of settings you can set here. DO NOT EDIT!

Database config

$config[‘db_host’] = “”;
$config[‘db_user’] = “root”;
$config[‘db_pass’] = “######”;
$config[‘db_name’] = “librenms”;

// This is the user LibreNMS will run as
//Please ensure this user is created and has the correct permissions to your install
$config[‘user’] = ‘librenms’;

This should only be set if you want to force a particular hostname/port

It will prevent the web interface being usable form any other hostname

$config[‘base_url’] = “/”;

Default community

$config[‘snmp’][‘community’] = array(‘public’);
$config[‘snmp’][‘community’] = array(‘Location1’);
$config[‘snmp’][‘community’] = array(‘Location2’);

Authentication Model

$config[‘auth_mechanism’] = “mysql”; # default, other options: ldap, http-auth
#$config[‘http_auth_guest’] = “guest”; # remember to configure this user if you use http-auth

List of RFC1918 networks to allow scanning-based discovery

#$config[‘nets’][] = “”;
$config[‘nets’][] = “”;
$config[‘nets’][] = “”;
$config[‘nets’][] = ‘’;

Uncomment the next line to disable daily updates

#$config[‘update’] = 0;

Number in days of how long to keep old rrd files. 0 disables this feature

$config[‘rrd_purge’] = 0;

Uncomment to submit callback stats via proxy

#$config[‘callback_proxy’] = “hostname:port”;

Set default port association mode for new devices (default: ifIndex)

#$config[‘default_port_association_mode’] = ‘ifIndex’;

Enable the in-built billing extension

#$config[‘enable_billing’] = 1;

Enable the in-built services support (Nagios plugins)
$config[‘show_services’] = 1;
$config[‘nagios_plugins’] = ‘/usr/lib/nagios/plugins’;

$config[‘debug’][‘run_trace’] = true;


#$config[‘traceroute’] = ‘/usr/bin/traceroute’;
#$config[‘traceroute6’] = ‘/usr/bin/traceroute6’;

Show names on dashboard

$config[‘force_ip_to_sysname’] = true;
$config[‘force_hostname_to_sysname’] = true;
$config[‘rrd_dir’] = “/data/rrd”;
$config[‘distributed_poller_memcached_host’] = “librenms”;
$config[‘distributed_poller_memcached_port’] = 11211;
$config[‘rrdcached’] = “Librenms2021:42217”;
$config[‘rrdcached_local’] = “unix:/var/run/rrdcached.sock”;
$config[‘rrdtool_version’] = “1.5.5”;
$config[‘log_file’] = “/data/logs/librenms.log”;
$config[‘log_dir’] = “/data/logs”;
$config[‘update_channel’] = “master”;

I cannot find the “rrdcached.sock” file.
Rrdtool version is 1.7.2.

I hope to get this resovled.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.