[FAIL] MariaDB version 10.2.2 is the minimum supported version as of March, 2021. We recommend you update MariaDB to a supported version 10.5 suggested). Failure to update MariaDB will eventually cause issues

Hi,

I am running lnms from the pre-built image based on Ubuntu 18.04 VM

My ./validate.php :

====================================

Component Version
LibreNMS 21.3.0
DB Schema 2021_03_17_160729_service_templates_cleanup (201)
PHP 7.4.16
Python 3.6.9
MySQL 10.1.47-MariaDB-0ubuntu0.18.04.1
RRDTool 1.7.0
SNMP NET-SNMP 5.7.3

====================================

[OK] Composer Version: 2.0.12
[OK] Dependencies up-to-date.
[OK] Database connection successful
[FAIL] MariaDB version 10.2.2 is the minimum supported version as of March, 2021. We recommend you update MariaDB to a supported version 10.5 suggested). Failure to update MariaDB will eventually cause issues.
[OK] Database schema correct

LibreNMS is working fine despite the error but I would like to upgrade MariaDB

Can you help me ?

I haven’t used the VM myself, but can’t you simply update the system packages inside it? sudo apt update && apt list --upgradable will tell you if there are updates see if newer mariadb is there, if so then just do sudo apt upgrade and it should be done.

I didn’t mention that Ubuntu is up to date,
I run a ./daily.sh too
and after a reboot, the error is still here

Hmm, how about https://mariadb.com/docs/deploy/upgrade-community-server-cs105-ubuntu18/, or alternatively, seeing as it is VM you can either make a snapshot or recreate it should it fail; and could try sudo do-release-upgrade to bring the base os up to 20.04 which would presumably run newer mariadb.

That concludes my grasping at straws.

1 Like

You are a magician hugalafuto :slight_smile:

I managed to update MariaDB by following your link
https://mariadb.com/docs/deploy/upgrade-community-server-cs105-ubuntu18/

now my ./validate is :

====================================

Component Version
LibreNMS 21.3.0
DB Schema 2021_03_17_160729_service_templates_cleanup (201)
PHP 7.4.16
Python 3.6.9
MySQL 10.5.9-MariaDB-1:10.5.9+maria~bionic
RRDTool 1.7.0
SNMP NET-SNMP 5.7.3
====================================

[OK] Composer Version: 2.0.12
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.